Showing results for 
Search instead for 
Did you mean: 
Advocate I
Advocate I

Scheduled refresh failure: An item with the same key - Merged queries



I've been trying to use the new Scheduled refresh option in Power BI Report Server October 2017.

The refresh fails with the message: "An item with the same key has already been added." when dealing with merged queries. It completes just fine when there is no merge action. 


I've tried renaming the columns/tables but it doesn't fix the problem. 

The merge action is very important so I can't delete it. 




The issue seems to be fixed with the March 2018 update!

View solution in original post

Advocate II
Advocate II

Hi all,


I can confirm the same issue on my end, with the added twist that I had a report working with a data refresh until I added a Merge Queries action.  I have resolved the situation using the stated workaround of making sure both queries involved in the merge action are sourced from a table rather than a SQL query.


In my specific case, I had a SQL view-based fact table with a column named "FiscalYear" imported using a SQL query that was filtering on a separate SQL view containing a limited number of fiscal years.  I also had a dimension table for the fiscal years using a table data source from the same view containing a limited number of fiscal years.


I then decided to limit the report to the current FY plus the prior 10, which required implementing the Merged Queries action on the fact table and a Keep First Rows action on the fiscal years dimension.  The data refreshed fine in PBIRS Desktop (October 2017), but the scheduled refresh under PBIRS failed.


For the workaround, I modified the data source for the fact table to pull directly from the view with no SQL query filtering in Power BI.  As soon as I did that, the Desktop refresh worked and running the scheduled refresh on the server also worked.


I hope this info helps identify the issue.  I am looking forward to the next release of PBIRS!

We've been experiencing this as well.

Raised as an issue, but haven't received any response as yet

The issue seems to be fixed with the March 2018 update!

View solution in original post

Thanks @Yousra for replying with the verification!

Helper I
Helper I

Same here... (PBI Server Version 1.1.6582.41691 (October 2017))


I got 2 tables as a web source and I need to merge them into 1 table.

These tables have already different column names but I tried to rename them in the merged table to make sure they are unique in Power Bi Desktop.

Manual refresh works fine... but scheduled refresh on Server doesn't work...



Hope someone has a workaround for this situation too 🙂




Frequent Visitor

I have the same Problem and i can't fix it...

I use the October 2017 Update 2.51.4885.1423 (x64).

I can refresh it in Power BI Desktop but not scheduled on the Reporting Service

Has anyone a solution for this ?


Frequent Visitor

Same problem here, the report refreshes fine in desktop, but not on the report server, if I cut out the merge it works fine, but then the report is not complete


Update I did some further testing and for me it seems to be when i use a SQL statement as the source and merge, if I dump the data into tables on a SQL server and use these for the merge, it refreshes on the server

Thanks @IGray for your suggestion.

Tried importing the data as a table instead of an sql query, then merging and the data refresh works!

Frequent Visitor

I have also discoverd you can use sql views to get around this problem

Frequent Visitor



I have the same issue when i try merge action. Do you know some solution of this problem ?

Community Support
Community Support

Hi @Yousra,


Are you able to refresh the report successfully in the Power BI desktop optimized for report server Oct version? 


Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes, the report can be refreshed using Power BI Desktop.

@Yousra thanks for reporting this issue and it is something we are looking in to. Do you have an isolated repro that you can private mesage me to help us reproduce this on our end? Thanks!

Hello @mgmeyer, I've sent you a private message including an example that reproduces the error.

Thank you!

Helpful resources

PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!