cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lorenz33
Helper II
Helper II

Scheduled Refresh failing after January 2021 Upgrade

Scheduled refreshes have been failing after upgrading to PBIRS January 2021.


SessionID: 83832121-9876-3fed-b88a-f123433bafe7
[0] -1056505856: COM error: Microsoft.PowerBI.ReportServer.ASEngineManagedRoot, No credentials were found for the datasource.
[1] -1055129594: The current operation was cancelled because another operation in the transaction failed.

The problem exists in our development environment and the credentials do exist and they work. The refresh works on the same report in our UAT environment. Both are have been upgraded to January 2021 (1.107698.27886). We caught it after the UAT upgraded. We do not want to upgrade production until this is resolved. Please let us know if there is a solution or workaround.

8 REPLIES 8
gsprague
Microsoft
Microsoft

Some users may find fixes for similar issues by checking this post Fix for "Datasource XXXXXX Not Found" PowerBI Refr... - Microsoft Power BI Community

parag_lokare
Frequent Visitor

We rebooted the server and the refreshes started working fine.

parag_lokare
Frequent Visitor

I created a simple report with just one dataset that returns one row. The schedule refresh fails with that error. Is there any solution for this? the system is an upgrade of PBIRS.  The schedule refreshes were working with the earlier Jan2021 release (1.10.7698.27886 (Build 15.0.1105.195). This is basic functionality of Powerbi should be fixed asap.  

Niki
Helper II
Helper II

@V-pazhen-msft 

i already posted multiple questions about this, I have the same problem!

We updated to the last version you mentioned above, but we have the exact same error on scheduled refresh.

Reports are all import report (that's why we need a scheduled refresh...) credentials are entered and correct. We have it in our productionenvironment, HELP. Exact same report does not give the problem in our testing environment....

V-pazhen-msft
Community Support
Community Support

@Lorenz33 

Which datasource did you use?  The RS version desktop does not allow a composite model.  This limited functionality means that all the tables must be exclusively the same type either import query mode or directly query mode. 

 

Also you should try update to the newest version for both Report server and desktop for RS(launched on Feb 5 2021).

 

Newest Report Server updated this month with fixes of some bugs.

V-pazhen-msft_0-1616657260591.png

 


Paul Zheng _ Community Support Team
If this post helps, please Accept it as the solution to help the other members find it more quickly.

Scheduled refreshes fail for all of the existing reports on this development server. I focused on one of the failing reports which has 2 queries from the same data source. I created a new report and used one of the queries from the failing report. I uploaded it, set up the data source and then a scheduled refresh. The scheduled refresh succeeded. I then added the second query to this report and made the report identical to the one that was failing. I uploaded it and ran a successful scheduled refresh. So we have 2 identical reports: One that existed before the upgrade where scheduled refreshes failed and another identical report that I just created where the scheduled refreshes are successful.

 

Scheduled refreshes work on our UAT server and it is running the January 2021 version. We compared PBIRS, SQL Server, and Windows server settings and they are identical.
We have no idea what can be causing this problem. Is this being looked into by Microsoft?

The data source is a query based on tables on one SQL Server database. The scheduled refresh does work for this same report in our UAT environment. Also, in our testing I created a simple report that pulls 10 rows from one SQL Server table and it still fails.

Paul, we have just upgraded to 1.10.7737.32652 in the development. The problem still exists.

The data source is just one SQL Server database. The credential are fine. Scheduled refreshes work on the exact same report and data source in the acceptance environment (1.10.7698.27886). We compared the 2 environments and could not find notable differences (yet). Any help in resolving this would be most appreciated.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors