cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
MajeedKhan Regular Visitor
Regular Visitor

Report elements Slow in loading on the server

I published my work to report server. Its working ok, but diffrent elements, like buttons, boxes, etc are slow in loading. how can i solve this, because its giving very bad user experience. 

1 ACCEPTED SOLUTION

Accepted Solutions
andris Regular Visitor
Regular Visitor

Re: Report elements Slow in loading on the server

Hi.

 

30-40 minutes is a really long time. If data load is not causing this and you don't have Performance Analyzer, I can only suggest to remove some of those images and see what happens with the performance. 

3 REPLIES 3
andris Regular Visitor
Regular Visitor

Re: Report elements Slow in loading on the server

Hi.

 

First, Connectivity Mode - is it DirectQuery or Import? If DirectQuery, the problem could be with data source performance, for example, need for indexes in source database tables.

 

Another cause of problem can be amount of visuals on report page. If there are lots of cards/charts/tables, all of them take some time to update and have to wait in queue, until they get processed. 

 

In May 2019 release of Power BI Desktop for Reporting Services there is new Performance Analyzer pane, try to turn it on and see, maybe there is some exceptionally slow visual. In Performance Analyzer pane you can see, how much time was taken by DAX query, refreshing of visual and "other" processes, which can include simply waiting.

MajeedKhan Regular Visitor
Regular Visitor

Re: Report elements Slow in loading on the server

Thank you for your reply. 

 

I have the Power BI January 2019 version that is special version to work with my Report Server so the performance analyzer is not there yet.

 

To address your question - I am importing data. the visuals are not so many, but i have many images used as icons on each page. the report have 26 pages in total

 

as you said, i waited for about 30 to 40 minutes and the missing visuals started appearing one after another. Will my users experience the problem? or once the visuals and images are processed my users will not have the same problem?

 

regards

andris Regular Visitor
Regular Visitor

Re: Report elements Slow in loading on the server

Hi.

 

30-40 minutes is a really long time. If data load is not causing this and you don't have Performance Analyzer, I can only suggest to remove some of those images and see what happens with the performance.