cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
muchinski Member
Member

Problem with a custom visuals in mobile App

When I publish a report using custom visuals on Power BI Report Server, these visuals are shown as an 404 error when I navigate using Android or iOS PowerBI App. If I navigate using the web portal, all runs normally.

 

Is anyone having the same issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Power BI Team jtarquino
Power BI Team

Re: Problem with a custom visuals in mobile App

You might need to uninstall and install the Power BI mobile app in order to force the clearing of the local cache.

 

Please try and let us know

5 REPLIES 5
Moderator mgmeyer
Moderator

Re: Problem with a custom visuals in mobile App

Unfortunately there was a bug in the GA release that prevents custom visuals from working in the Mobile apps in some cases, we are working on a fix and it should be released shortly. Apologies for the inconvenience.

shiboli Regular Visitor
Regular Visitor

Re: Problem with a custom visuals in mobile App

We just pushed a new update with fix for this issue: https://aka.ms/pbireportserver

 

Please try and see if this solves your problem.

muchinski Member
Member

Re: Problem with a custom visuals in mobile App

Hello,

 

Thank you for the quick replying! 

 

I updated to the last version (server and desktop) and created another sample report using three different custom visuals:
- Chord 
- Heatmap

- Dual KPI

Results on Mobile:
Only Dual KPI custom worked

 

Screenshot_20170717-111226.jpg

 

Power BI Team jtarquino
Power BI Team

Re: Problem with a custom visuals in mobile App

You might need to uninstall and install the Power BI mobile app in order to force the clearing of the local cache.

 

Please try and let us know

muchinski Member
Member

Re: Problem with a custom visuals in mobile App

Hello,

 

Reinstalling the app worked perfectly both Android and iOS devices. 

Just for documentation, the app was installed for the first time on May/2017 on both devices of my company and it was updated to the last version.

 

Thank you!