cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Petebro
Microsoft
Microsoft

Power BI Report Server October 2020 update has been released.

Hello,

 

I am pleased to announce we have released an update to the Power BI Report Server (October 2020) with several fixes to problems commonly reported here on the Power BI Community Forums.  The release can be found here:

https://www.microsoft.com/en-us/download/details.aspx?id=57270

 

Changelog will be updated tomorrow with the following information: 

 

Version: 1.9.7627.11028 (Build 15.0.1104.264), Released: November 18, 2020
        - Bug fixes
            - Fixed issue preventing users from changing fields in site settings via the portal.
            - Fixed issue with refresh of Power BI Reports when using 'EnterData' data source.
            - Fixed issue with refresh of some models using enhanced dataset metadata.
            - Fixed issue where some Power BI reports could not be published to the Report Server from Power BI Desktop
 
Thanks for being active part of the Power BI community and please let us know if you run into any problems.
 
-Pete
97 REPLIES 97
powerbi43
Frequent Visitor

I was given the same work-around from someone from Microsoft earlier today.  I was also told this was going to be fixed during the January 2021 release.

powerbi43
Frequent Visitor

We continue to have problems with the October 2020 release even after applying the update.  We continue to get 'credentials missing' errors even though there are credentials.  I've created a support ticket, but that hasn't helped yet.  Is another patch being worked on?

jimv2000
Regular Visitor

I managed to fix this. I tried a fresh install on my own PC and everything worked fine, which led me to think that something was messed up with the update process. I then turned off the Power BI service on the server, renamed C:/Program Files/Microsoft Power BI Report Server, and ran the installer again with the "Repair" option. Once it was done, I copied the config files from the old install folder to the new one. These files were:

C:\Program Files\Microsoft Power BI Report Server\PBIRS\Portal\RSPortal.exe.config
C:\Program Files\Microsoft Power BI Report Server\PBIRS\PowerBI\RSPowerBI.exe.config
C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\rsreportserver.config
C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\rssrvpolicy.config
C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer\web.config
C:\Program Files\Microsoft Power BI Report Server\PBIRS\RSHostingService\RSHostingService.exe.config

I don't know that all these configs were necessary, but I copied them anyway just to be safe. Also, I did not try just doing a straight repair first...that might have been enough to fix it. The rename/repair/replace definitely fixed it. Now my dashboards that were broken are refreshing like they should.

mroldao
New Member

Hi,

 

My company have PowerBi Report Server working about 2 years and doing all the upgrades and never goes wrong.

This time, when upgrades to Oct 2020, after that, some reports, with google sheets, csv and excel as datasources stop schedule refresh.

Some erros comes like:

 

"COM error: mscorlib, An item with the same key has already been added."

"The module named 'Html' has been disabled in this context"

"COM error: Microsoft.PowerBI.ReportServer.ASEngineManagedRoot, Datasource xxxxx is not found."

 

What happend?

I try some workarounds, some people suggest, but didn't work for me.

Rollback to previous version is not possible, Microsoft will repair this in next version?

 

Thank you.

Regards

Anonymous
Not applicable

Hello again,

I have tried this but I still have the same error below:
0] -1056505856: COM error: mscorlib, An item with the same key has already been added..

 In order to know the source of the problem, I have deleted all Merges in the dashboard => the Scheduled Refresh worked.
Once I do a simple merge, the Scheduled Refresh works on the desktop but not on the Server(with the same error).

I am really confused here. Could you help me, please?

josef78
Continued Contributor
Continued Contributor

Another issue with October version (18th NOV build) with enabled "Enhanced Metada format". Not critical. But we are not able save reports with "IBM Netezza" conector with error "There was an error uploading your .pbix file."

 

Saving to Power BI Report Server (2nd October release) from PBI Desktop RS May 2020 or from October with disabled Enhanced Metadata format, works fine.

 

Also all current reports (saved from PBI Desktop RS May 2020 or from October with disabled Enhanced Metadata format) works fine including scheduled refreshs. 

 

It is definitely issues in new metadata format (I don't  know if on Server or Desktop side, or both).

 

Why why why this first "PREVIEW", unfished and buggy feature, is in production release, set as enabled by default?????

Why was not be re-released Desktop application with by default disabled this featerure, immediately when it shown as big problem?

 

jcaranibar
Helper I
Helper I

@gboreki How can I send you "privately"?

Click on my alias here, and in the profile page on the top right corner there is an option to "Send this user a private message". 

About gboreki - Microsoft Power BI Community

 

Thanks

jimv2000
Regular Visitor

@Petebro @gboreki 

I installed the 11/18 update this morning. The version shows 1.9.7627.11028 and the server has been rebooted. Dashboards with failing scheduled refreshes have not started working again.

For a test, I created a simple dashboard with the Enhanced Metadata option disabled. It runs "SELECT TOP 100 * FROM ReportServer.dbo.DataSource" (a database and table that everyone here should have) and displays a few fields in a table visual. I published that to PBIRS and scheduled refresh worked fine. I then enabled the Enhanced Metadata option, restarted PowerBI Desktop, then re-opened my test dashboard, saved it, and tried the scheduled refresh again. It failed immediately with the "The credentials provided for the SQL source are invalid" error, despite the credentials being valid when I click the test button.

I also tried creating a new, blank dashboard with Enhanced Metadata enabled, put the same query and visual, and it also failed to refresh.

jcaranibar
Helper I
Helper I

We have been using PBI RS for more than 2 years. Every upgrade was wonderful until Oct/2020. A lot of problems, issues and bugs at server side. We installed update of Nov18th but still having problems with: connection strings, scheduled refreshes of SQLS direct query reports, credentials unknown. The strange thing is that everything is ok in Desktop but in the server is not working. We saw a lot of posts and tried many suggested solutions but the problem is not solved. We applied pbix files without enhanced metadata option, which incredibly came selected by default! but is not a solution. We are clearing logs and resetting service, which solved momentarily until something happens (we don’t know what and when) which crashes reports again. We tried to change connection string with PowerShell without success. We created a couple of tickets to receive support but engineers don’t know what is happening, and after 2 weeks there is no definitive solution (in the past we created around 15 tickets solved in 3 days at most). We shared with them log files, configuration files, screenshots, but the solution is not near and ther is no escalation. We restored .pbix from backup folder but names are strange and we needed to identify them manually opening them. Once those are on the server, errors appear. Now there is a mix of pbix files some with simple connection string and some other with explicit connection strings. Don’t know which are ok.

We never faced this kind of situation. Many disappointed technicians, many unhappy users. I don’t think going back to May version is an option. Please @Petebro @gboreki and MSFT guys, help us to retake normal operations of PBI RS reports, as always was after an upgrade! Is all of these connected to have received version after a month which was the original plan (Oct instead Sep)?

 

JCA

Hi @jcaranibar ,

 

Sorry to hear about your issues. Sounds like there are a couple of different problems you are hitting. Just to clarify, the issues that have been posted here with refresh are all when reports are updated with "Enhanced metadata" option, to my knowledge there are no issues in october release when this flag is turned off in desktop. Also, please ensure you have updated to the version released on Nov 18th, as that had fixes for multiple issues reported here.

 

If you have active cases open with our support team, do you mind to send me privately the case numbers and I can check the status of those cases.

 

Thanks

-gboreki

We do have ssrs reports which are having the same refresh problem.

Oct 2020 Schedule refresh not working - Microsoft Power BI Community

 

DenisPH
Regular Visitor

Actually it is a shame. After every update there are problems which are - if at all - only solved with several fixes.
Do you not test internally at all before an update is rolled out?


We have the latest update, both for the report server and the desktop application.

I have an older Report with a Direct Query Data Source (to SQL Server 2019), after the update I only changed the sorting of a table and saved it again. Since then, the report isn't working at all. Every time I get the following error message:

We couldn't connect to the Analysis Services server. Make sure you've entered the connection string correctly.


Credentials are correct (Test connection is working), Data Source as mentioned is a sql server 2019 database.


Please fix the issues and for upcoming releases... test it!

braddo81
Helper I
Helper I

we have the issue, latest build didn't resolve

credentials missing error

AndreasScholl
Helper I
Helper I

Hello Support Team,

 

is there anything new on this? We are still not able to update our productive environment because of that.

 

Best regards

Hi,

 

Here another interested on this evolution to fix reported issues.

Thanks a lot for your opinion.

modasher
Advocate I
Advocate I

Hi,

 

I removed a few tables in transform data space, then hit close and apply. After coming back although the tables were not showing up in Report and Data views, they did however still show in the Model view. And when trying to remove them from the Model view, it would show an error. 

 

Has anyone here tried this yet?

 

Regards,

Modasher.

erbash23
Frequent Visitor

Dear Responsibles,

 

Could You please share roadmap about solving these issues. 

 

pabeader
Helper IV
Helper IV

Ever since the 'update' I've been getting this error message.  Not EVERY time it tries to refresh, it happen about 80% of the time.

 

[0] 0: Failed to publish model for

 

 

If it trry multiple times, it will eventually get a refresh.  But then fail the next time around.

 

 

Please help.

Anonymous
Not applicable

Hi, 

We have been using a specific dashboard for over a year and everything worked just fine. However, now After installing Power BI October 2020 version and when we have got the latest updated version we are getting the below error:

SessionID: 6e1991ba-35e2-4372-95eb-e2eb0a2f5d84
[0] -1056505856: COM error: mscorlib, An item with the same key has already been added..
[1] -1055784828: The database operation was cancelled because of an earlier failure.

Report data sources are mainly SQL databases and Excel Files. We have also done some Merges and Appends. I have used the remove duplicated rows in Query(even that there are no duplicated rows) and renamed columns that have the same name, but nothing works. Also, I have tried this  https://community.powerbi.com/t5/Report-Server/Power-BI-Report-Server-October-2020-update-has-been-r...  and disable the Feature'' Store datasets enhanced metadata format''. unfortunately, nothing worked.

The dashboard is very important to us and was working perfectly. Could you please provide me with a solution?

Thank you for your time and consideration in regard to this matter,
I look forward to hearing from you very soon,

Best Regards,

Hi,

I had face a similar issue. It seemed to me that somehow Power Bi was detecting that there was a duplicate of the same report, as I had downloaded the report and tried to save it in a different location by renaming it, but it won't allow me. I made a fresh copy of the report by making transformations in the Query Editor/Transform Data, and copied the visuals- Later when saved it in RS, it didn't show up that error. 

 

Was troublesome to go through scratch again, but that was the quickest solution I got to get the dashboard running back in corporate environment.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.