cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mhammo
Helper I
Helper I

Power BI Report Server Azure Image Missing PBI Components

Hi,

 

I just setup the Power BI Report Server Azure Image found in the marketplace:

 

https://azuremarketplace.microsoft.com/en-us/marketplace/apps/reportingservices.technical-preview?ta...

 

The descriptions says it includes everything: 

 

"This image deploys Power BI Report Server, which is compatible with Reporting Services reports, allowing the deployment and distribution of interactive Power BI reports and traditional paginated reports. This environment is licensed for development and testing only, not production. It is a pre-configured environment that includes all the Server components (Power BI Report Server, SQL Server Database Engine, SQL Server Analysis Services), client tools (Power BI Desktop, Mobile Report Publisher, Report Builder, SQL Server Data Tools) and sample demo content to preview the new functionality in Power BI Report Server. "

 

BUT, I am not finding ANY Power BI related apps, demo's or content. It does have SQL Server 2016 installed but nothing else. Not even the report server. Where is the Power BI related tools and content?

 

Mike

1 ACCEPTED SOLUTION

@itretyakov @bprerad @jvdl @mhammo we just deployed the updated template and we tested the regions that were mentioned in this thread. Please give the latest template a try and let us know if you run into any issues. Thanks for your patience in helping us resolve this.

View solution in original post

16 REPLIES 16
itretyakov
Regular Visitor

Same issue here. I tried South East Asia region, nothing related to Power BI is installed. I tried now West US and same issue

@itretyakov @bprerad @jvdl @mhammo we just deployed the updated template and we tested the regions that were mentioned in this thread. Please give the latest template a try and let us know if you run into any issues. Thanks for your patience in helping us resolve this.

View solution in original post

bprerad
Frequent Visitor

thanks @mgmeyer

 

I have deployed the image and it works as expected. Thanks for the support.

jvdl
Frequent Visitor

@mgmeyerMicrosoft charged me $5 for installing the previous template and running it for a day or two only to discover it didn't work due to nobody's fault but Microsoft's.

 

So thank you very much but no thanks. You can hire your own beta testers in Seattle.

We've made a fix and we're waiting for approval to get the updated template published, it should be resolved soon. Thanks for your patience and reporting the issue.

v-qiuyu-msft
Community Support
Community Support

Hi @mhammo,

 

Based on my test, this image can have the Power BI desktop, Report Server Configuration Manager installed. See:

 

w1.PNG

 

sample demo content stored on Power BI report server, you can open the Report Server Configuration Manager -> Web Portal, click the URL to go to the web portal to see content.

 

w2.PNGw3.PNG

 

By the way, you can get started with Power BI Report Server here.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-qiuyu-msft: Not true.

When installing end of month July 2017 there is nothing related to Power BI on the VM image.

The report server configuration manager only brings up a 1990's style SQL Server reporting tool that can only spit out ugly looking GIFs. The web portal URL is not accessible from outside the VM localhost.

 

Total waste of time and money.

@mhammo & @jvdl I just created a fresh VM using the Azure template and everything is there, when I log in using the user specified when I created the template the desktop has shortcuts pointing to the ReportServer URL, Sample PBI Reports, PBI Desktop RS and SQL Data Tools. Can you both try to create a new VM and see if it resolves the issue. My guess is something happening during the provisioning which prevented the full setup of the VM. Thanks!

Hi @mgmeyer  I just created another image, using the template, and there is still nothing at all related to Power BI on this machine. I searched the entire hard drive and the temporary storage drive. 

 

This is the link I am using: https://azuremarketplace.microsoft.com/en-us/marketplace/apps/reportingservices.technical-preview?ta...

 

Is there a different one that you are using?

 

Mike

Yep I clicked the link you had in the original post, that is odd that you aren't seeing anything. Couple questions:

 

  1. If you navigate to the C:\Program Files\ on the VM do you not see a 'Microsoft Power BI Report Server' folder?
  2. Can you check the 'Acitvity Log' in the Azure portal for the VM that you created and see if anything is reported there? For me I just have one entry 'Write VirtualMachines' and the status is succeeded.
  3. Also under the Overview properties for you VM what location is it in and also which size VM did you use? Mine is in West Coast and the size is D12

Thanks!

Hello,

 

1. Nope, that folder does not exist.

2. I see the same message.

3. Mine is US East and I think mine was the D11_V2. 

 

Just to try something different, this time I installed the template from within my Azure Portal. Just logged off that machine and it too has absolutely no sign of Power BI at all.

 

And thanks for your help.

 

Mike

Ok, I was able to reproduce the issue with nothing being installed; not sure why but the region seems to have something to do with it. I created a new VM in East US using the DS11_V2 VM size and nothing was installed. I then created another VM using the same size but in West US and it worked. Also I noticed that with the smaller VM size (note the recommended size is DS12 or DS12_V2) some of the post provisioning steps took a little longer even though Azure reported the VM as ready. Can you try a new VM in East US 2, I just created one there and everything was installed.? I'll see if I can figure out what is going on with the East US region, thanks for reporting this.

 

@jvdl Can you let me know which region you created your VM in also what VM size you used. Thanks! 

Ok, had multiple problems throughout the day getting the PBI Report Server image to load at all, on any image and any region.

 

Finally, was able to configure it for West US and this image has all of the links and examples. 

 

Thanks @mgmeyer for tracking this down to a region problem. Odd, but, at least I now have an image that I can review and test.

 

Mike

No problem thanks for reporting the issue, we're looking into why it isn't working in certain regions. As soon as we have a solution I'll report back to the thread to give an update.

bprerad
Frequent Visitor

Hi @mgmeyer.

 

I have the same issue as @mhammo but was not able to resolve by using other regions. I have tried all available regions for my subscription (East US, SouthCentral US, West US2, West Central US, Southeast Asia, West Europe). 

 

Did you manage to find the reasons why is there no PBI on deployed images? Is there any workaround?

 

regards,

Bojan

jvdl
Frequent Visitor

I'm in West Europe

Helpful resources

Announcements
MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps