cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
markwilson
Frequent Visitor

Power BI Paginated Report Image doesn't display

Hi,

 

I am trying to display images in a Power BI Paginated Report using the External mode. An example URL which has the behaviour I am experiencing is this:

 

https://community.powerbi.com/t5/image/serverpage/image-id/564756i1FDAD52761F66EEC/image-size/medium...

 

This image renders when you are in design mode, but when you switch to Run mode the image doesn't display. It also doesn't display when you publish the report to a workspace.


1 ACCEPTED SOLUTION

Yes, it sounds like your problem and mine are functionally identical.  I solved it in two different steps:

1. I wrote another program to download all of the images I wanted to access and uploaded them to another website, so that I was calling them via a standard URL, not a webapi call. Technically the Webapi is downloading them, not accessing them as image links I guess. Then I modified the query that had the URL to point to the new location.

 

2. Additionally, I resized all of the images which were bigger than 4MB, shrinking them down in size. For some reason report builder doesn't like it when they are too big. In my case they were photos so they looked just fine between 2 and 4MB.

View solution in original post

5 REPLIES 5
markwilson
Frequent Visitor

Lucien, thanks for your detailed response. The image in the link is not a screenshot of my problem, rather it is evidence of it.

 

If you follow your steps above and use the link that I provided in step 5, yo uwill see that the image renders successfully in design mode, but then when you actually RUN the report it fails. This is my problem.

Hi Mark

 

Did you ever manage to sort this one?

 

I'm seeing exactly the same issue - I put the link to the image in report builder and can see the image in designer, then nothing when I run the report.... The link works fine in PBI too.

 

One thing on my URL... its a weblink to an image, but the image is rendered through an API on the web, so I don't have a .jpeg extension or anything like that.... Not sure if that makes any difference!

 

Any help appreciated!

Yes, it sounds like your problem and mine are functionally identical.  I solved it in two different steps:

1. I wrote another program to download all of the images I wanted to access and uploaded them to another website, so that I was calling them via a standard URL, not a webapi call. Technically the Webapi is downloading them, not accessing them as image links I guess. Then I modified the query that had the URL to point to the new location.

 

2. Additionally, I resized all of the images which were bigger than 4MB, shrinking them down in size. For some reason report builder doesn't like it when they are too big. In my case they were photos so they looked just fine between 2 and 4MB.

Amazing - thanks so much for the reply!! 🙂

v-luwang-msft
Community Support
Community Support

Hi @markwilson ,

I clicked on your link, but the picture is not clear enough to see the exact details of the steps. You can try to follow the steps below.

  1. In report design view, on the Insert tab, click Image.

  2. On the design surface, click and then drag a box to the desired size of the image.

  3. On the General tab of the Image Properties dialog box, type a name in the Name text box or accept the default.

  4. (Optional) In the Tooltip text box, type text to display when the user hovers over the image in a report rendered for HTML.

  5. In Select the image source, select External.

    For an image on a report server in native mode, type a relative path to the image in the Use this image box-for example, ../images/image1.jpg.

    For an image on any Web site (including a report server in SharePoint integrated mode), type a full URL to the image in the Use this image box: for example, https://\<SharePointservername>/\<site>/Documents/images/image1.jpg.

    For more information, see Specifying Paths to External Items (Report Builder and SSRS).

  6. (Optional) Click Size, Visibility, Action, or Border to set additional properties for the image report item.

  7. Click OK.

To learn more details ,refer:

https://docs.microsoft.com/en-us/sql/reporting-services/report-design/add-an-external-image-report-b... 

https://docs.microsoft.com/en-us/sql/reporting-services/report-design/images-report-builder-and-ssrs... 

 

And similar question refer:

https://community.powerbi.com/t5/Service/cannot-display-image-in-paginated-report/m-p/1799722 

 

Did I answer your question? Mark my post as a solution!


Best Regards

Lucien

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.