cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vdusan Frequent Visitor
Frequent Visitor

Paginated report problem in PBIRS

We have a PBIRS instance at our production environment, where the same user (with admin rights) uploaded both PBIX and SSRS paginated reports. Other users can access PBIX reports but paginated SSRS reports are not available. When those reports are clicked on they give us a login prompt but after a couple of tries at the prompt nothing comes up in the portal (blank page). It used to work and last week it stopped. We have test environment in different domain and it works withot error.

 

We've tried everything. When we use fiddler to trace it we get http 401 (unauthorized) error. We've created the report (rdl) which only display title without any database connection and we got the same error.

4 REPLIES 4
RobThrive Regular Visitor
Regular Visitor

Re: Paginated report problem in PBIRS

Is it asking you for login details for accessing the report, or is it asking you login details to the data source because they were not set in the RDL file before you uploaded it?

If you have a custom data source (not shared) go to Manage --> Data source and ensure the correct user details are setup for accessing the data source.
If you are using a shared data source, go ensure that is setup with the correct user details.

If you are being prompted for user to login to access the actual report, check Manage --> security on the file.
vdusan Frequent Visitor
Frequent Visitor

Re: Paginated report problem in PBIRS

It is asking me for login details for accessing report.

 

Security is OK, both custom data source and and shared data source are setup correctly. All reports work OK except paginated reports. 

 

 

RobThrive Regular Visitor
Regular Visitor

Re: Paginated report problem in PBIRS

Have you checked the log file in the PowerBI RS install directory. I find it often has a lot more information available there.
vdusan Frequent Visitor
Frequent Visitor

Re: Paginated report problem in PBIRS

Hi, 

Yes I have. There is nothing in the log file, nothing in the events. It was working and than just stopped. Nothing was changed on the server and in our domain(update, security...)

 

In fiddler I can see http 401 for paginated reports for all other reports everything is ok. When I click on the report I get logon screen. When I enter my credentials 3 times I get blank page.

 

Very strange.

Helpful resources

Announcements
New Topics Started Badges Coming

New Topics Started Badges Coming

We're releasing new versions of the badge that everyone's talking about. ;) Check your inbox for notifications.

MBAS 2020

Save the new date (and location)!

Our business applications community is growing—so we needed a different venue, resulting in a new date and location. See you there!

Difinity Conference

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Kudoed Authors (Last 30 Days)