cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TiagoCosta1983 Frequent Visitor
Frequent Visitor

Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

Hey Guys,

 

This is the first time I test the PBRS and found a small issue with this version.

We tried to move some SSRS reports to the PBRS and they seem to work ok in IE ,Edge and Firefox , but when we open them on Google Chrome , if the report has parameters, even if you change the parameters it resets to the default value and does not render the report.

 

Here are some SCs:1.PNG

Chrome (can't change date parameter since it always reverts to default) : 

2.PNG

 Edge:

3.PNG

 

Do you think this is a PBRS issue or a Chrome issue? 

Any advice ?

 

Something to fix in the server in the future? 

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
TiagoCosta1983 Frequent Visitor
Frequent Visitor

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

It seems that it had to have with my form saved data and password saved data, once I deleted that it worked... 

Still a very strange issue that data from another sites afects this ... 

 

nevertheless.. mistery solved.

6 REPLIES 6
Moderator v-qiuyu-msft
Moderator

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

Hi @TiagoCosta1983,

 

Based on my test in Power BI Report Server Version 14.0.600.434, we are able to change data from calendar in Chrome browser. In your scenario, please clear the Chrome browser cache and try the same browser version as ours. 

 

q3.PNG

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
TiagoCosta1983 Frequent Visitor
Frequent Visitor

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

@v-qiuyu-msft

 

I can change the data within the parameter, but the moment I click "View report" he actually goes back to the original value and does not show the data that I need :/

 

Sorry for the confusion btw.

Moderator v-qiuyu-msft
Moderator

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

Hi @TiagoCosta1983,

 

I'm not able to reproduce the issue. Please clear cache and try the same browser as mine then test again. 

 

q4.PNG

 

Best Regards,
Qiuyun Yu

 

 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
TiagoCosta1983 Frequent Visitor
Frequent Visitor

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

@v-qiuyu-msft

Super Strange, I just cleared the cache, I've tested in MAC and WIN and on both systems I get the same issue.

All other Browsers are ok.

 

My version of the PBRS is 14.0.600.434.

 

 

Now I've tested on a fresh install on the server itself and worked! But if I try on my windows and after clearing the cache , disabling all plugins it still does not work... super strange... I really don't get it.

 

Both versions of chrome are the same ! :/ I'm confused.

 

 

TiagoCosta1983 Frequent Visitor
Frequent Visitor

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

@v-qiuyu-msft

OK , after some digging I believe I found the issue (super strange one):

 

With a fresh install of Chrome (no account signed in ) it works ok.

 

The moment I sign in my account it stops working. 

I also tried disabling all my plugins but no dice.. stops working... and it feels that the view report always refreshes the report.

 

TiagoCosta1983 Frequent Visitor
Frequent Visitor

Re: Paginated Reports with Parameters not working properly on Chrome (62.0.3202.89)

It seems that it had to have with my form saved data and password saved data, once I deleted that it worked... 

Still a very strange issue that data from another sites afects this ... 

 

nevertheless.. mistery solved.