cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
laaxy Frequent Visitor
Frequent Visitor

PBIRS not working properly when HTTPS is configured

I have a PBIRS Instance Version 14.0.600.442 running on a Windows Server 2016.

When the Instance is configure to use HTTPS i am unable to deploy Reports from a Power BI Desktop or even upload pbix files to my PBIRS. When I remove the HTTPS URL and configure the HTTP it works as expected.

 

I configured the HTTPS URLs the same way as I would for a SSRS Instance (https://docs.microsoft.com/en-us/sql/reporting-services/security/configure-ssl-connections-on-a-nati...).

 

Can anyone help me?

I really need my PBIRS Instance to only be accessible through HTTPS.

1 ACCEPTED SOLUTION

Accepted Solutions
laaxy Frequent Visitor
Frequent Visitor

Re: PBIRS not working properly when HTTPS is configured

In my Log file C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles\RSPortal_yyy_mm_dd.log I found the following error:

 

"The remote server returned an error: (401) Unauthorized."

 

I've done the following change on the Server Regestry:

     1) Open Registry (regedit)

     2) Locate the registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

     3) Right-click Lsa, point to New, and then click DWORD Value.

     4) Type DisableLoopbackCheck, and then press ENTER.

     5) Right-click DisableLoopbackCheck, and then click Modify.In the Value data box, type 1, and then click OK.

 

After this change I was able to deploy PBI Reports on the Instanz using the HTTPS link (HTTP link is disabled)!!!

 

4 REPLIES 4
CorgiLover Regular Visitor
Regular Visitor

Re: PBIRS not working properly when HTTPS is configured

I am having the same issue here. By any chance you have a fix?? Thanks!

irvmic Frequent Visitor
Frequent Visitor

Re: PBIRS not working properly when HTTPS is configured

I had the issue but one of the later builds resolved the problem for me.

 

Currently using Version 1.2.6690.34729 (Build 15.0.2.402), Released: April 27, 2018

laaxy Frequent Visitor
Frequent Visitor

Re: PBIRS not working properly when HTTPS is configured

I have 4 Servers running the latest Build 15.0.2.402.

On 2 of them the Problem appeared to be solved with the new Build. But on the other two I still have the same Problem.

Has anyone experience the same situation and has a solution?

laaxy Frequent Visitor
Frequent Visitor

Re: PBIRS not working properly when HTTPS is configured

In my Log file C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles\RSPortal_yyy_mm_dd.log I found the following error:

 

"The remote server returned an error: (401) Unauthorized."

 

I've done the following change on the Server Regestry:

     1) Open Registry (regedit)

     2) Locate the registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

     3) Right-click Lsa, point to New, and then click DWORD Value.

     4) Type DisableLoopbackCheck, and then press ENTER.

     5) Right-click DisableLoopbackCheck, and then click Modify.In the Value data box, type 1, and then click OK.

 

After this change I was able to deploy PBI Reports on the Instanz using the HTTPS link (HTTP link is disabled)!!!