cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rkapukaya
Helper I
Helper I

PBIRS Odata - cannot pull data with url from shared datasets

Hi,

I've been using PBIRS.  i want to use shared datasets in my powerbi reports with odata.

 

I created shared datasource and shared dataset (using shared datasource).

When run the url above, i got shared datasets list on my PBIRS. this link downloads with json file format and i can see my shared datasets.

 url : https://myservername/reports/api/v2.0/datasets

 

when i run this url to see data on shared datasource, it throws error;

url : http:s//myservername/reports/api/v2.0/datasets(fb3ceb83-3b05-4512-b543-2b83bd30da6e)/data

error description : 

 

{"error":{"code":"220","message":"The data set could not be processed.","details":[{"code":"222","message":"There was a problem getting data from the Report Server Web Service: The operation you are attempting on item '/MyFolder/Dataset1' is not allowed for this item type. ---> Microsoft.ReportingServices.Diagnostics.Utilities.WrongItemTypeException: The operation you are attempting on item '/MyFolder/Dataset1' is not allowed for this item type."}]}}

 

so, i can not work with this url on odata on powerbi desktop. what should i do?

 

2 REPLIES 2
Icey
Community Support
Community Support

Hi @rkapukaya ,

 

1. Is this just a clerical error?

 


 

when i run this url to see data on shared datasource, it throws error;

url : http:s//myservername/reports/api/v2.0/datasets(fb3ceb83-3b05-4512-b543-2b83bd30da6e)/data

 

 


2. Please check if this post is helpful: 


 

 

I removed the database from the AG and still not working.  I did find something interesting that led me to a solution.  While in reporting services connection manager I clicked the URL for the Web Service.  It prompted me for credentials.  I was able to get to the web service after entering valid credentials.  On a hunch that this could be the issue.  I added an URL that is configured for all assigned IP addresses.  The URL that is created is server name/reportserver.  When I click on this new URL it get directly to the web service without having to enter credentials.  Now preview works and I can load a dataset in Mobile Report Publisher.  All is working now.

I originally configured the URL to be the AG listener for the AlwaysOn AG.  This was causing a prompt for credentials.  Now that I have added the new URL everything is working.  Although probably not in the case of a fail-over.

I guess now my question would be is there a setting that would prevent the credentials being prompted on the AG listener URL.

Thanks

 

  • Edited by scowger Tuesday, February 7, 2017 6:24 PM edit grammer
  • Marked as answer by scowger Tuesday, February 7, 2017 6:33 PM

 

Reference: Data Preview Error in SSRS 2016 (microsoft.com)

 


 

 

Best Regards,

Icey

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Icey 

 

1) sorry, i copied wrong. It starts with https://....

 

2) When i clicked report server url nothing shows up.

 

After that, i tried another steps;

 * Open new PBIRS desktop and exract table from database

 *  I changed code on advance editor like below and error came up;

My odata feed code;

 

let
Source = OData.Feed("https://MyReportServer/Reports/api/v2.0/datasets(DataSetId)/data",null, [MoreColumns=true])

in
Source

 

 

 

Error description;

 

DataSource.Error: OData: Request failed: The remote server returned an error: (422) Unprocessable Entity. (The data set could not be processed.)
Details:
DataSourceKind=OData
DataSourcePath=https://MyReportServer/Reports/api/v2.0/datasets(DataSetId)/data
Url=https://MyReportServer/Reports/api/v2.0/datasets(DataSetId)/data

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!