cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Carli
New Member

PBI Report Server doesn't render correct font for groups that toggle hidden fields

In paginated reports where I added groups that can be used to toggle hidden fields, the font and fontcolor of those groups is not displayed correctly.
I use a XML dataset which holds the fonts and colors I want to use in my reports. When I preview the report in Visual Studio, Report Builder or SharePoint everything looks fine, but when I deploy it to SSRS PowerBI I see a font that looks like Times New Roman instead of Segoe UI that it's supposed to show. The fontcolor is black, while it should be red. It does show the correct backgroundcolor.
When I do not use the dataset to render the font and just add Segoe UI in the textbox properties everything works fine.

 

ExampleExample 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Is this a bug or am I missing something?

5 REPLIES 5
ruzickaf
Regular Visitor

Although this message is quite old, I'm also still facing the same problem. However, I haven't found any solution across entire internet. If I design a paginated report using Visual Studio 2012 then the rendered result will look correct. On the other hand, if I deploy the same report (RDL file) into the Power BI Report Server (ver. 1.4.6969.7395 January 2019), every textbox in the role of group header - toggle item (expand/collapse provided by sign +/-) is rendered incorrect in browser IE 11. I've already read here about different rendering engines (GDI in VS vs. browser) but I really would like to know how to figure out this problem.

Any ideas are highly appreciated!

 

Incorrect group rendering in the PBIRSIncorrect group rendering in the PBIRSCorrect group rendering in the VS2012Correct group rendering in the VS2012

Jon-Heide
Microsoft
Microsoft

Hi Carli - are you using HTML styling from the database? Or are you parsing an XML file from the DB and setting those as expression based styles?

 

Note that RB and and VS in preview render through GDI and the server through HTML in the browser. In some cases the fonts avaialble can be different (ensure the appropriate fonts are installed on the server and clients). Also attaching the RDL can be helpful to diagnose.

Thanks for your reply Jon-Heide.

I am using expression based styles from an XML file.

If the font wasn't installed wouldn't I have problems with all textboxes in which the font is used? I only have problems with the toggle-textboxes.

I will try to attach the RDL-file. I'm new here so I have to find out how to do that. Smiley Happy Or do you want me to post the code here?

I'm having the same issue, except I'm pulling the FontFamily value from a relational database and setting it in the cell as an expression. I did find that hardcoding the font family resolved the issue, but this is not an ideal long-term solution. Is there a fix in the works for this?

I forgot that I'd already had this problem, and found my own reply when searching online for a solution. 🙂

 

Anyone else experience this? Any solutions?

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.