cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gervaisper
Regular Visitor

On premise data gateway, invalid username or password error for SSAS

Hi everyone,

 

I try to make a connection to my SSAS cube via Standard on-premise data gateway and I always get an invalid username or password error!

 

Here are the configuration that I did after reading troubleshooting doc:

 

  1. The gateway service run with my windows account, this acccount is administrator on the server.
  2. My UPN and windows account are set correctly in our organization AD. TGGAU is set correctly for our domain.
  3. The command "whoami /upn" return the good email adress used to connect to PowerBI service.
  4. The SSAS server belong to the organization domain.
  5. All the other connection type like Sql server, Excel file are working properly.
  6. We use Sql Server 2019 Enterprise version.
  7. When I try to run a report (with SSAS as datasource correctly configured) in Power BI service, I see the trace on SSAS (profiler) and I see that the NTDomainName and NTUserName are passed correctly to SSAS, but an invalid username or password message is generated.
  8. In SSAS, my account is a server administrator and I add the account as full control role for the SSAS database.
  9. We use a specific port to access the SSAS server, not the default one.
  10. In SSMS, when I try to connect to SSAS with the Additionnal Connection Parameters : EffectiveUserName=aaaa.bbbb@ccc.ca, I am not able to connect, it generate the same error as I have with the gateway.

What am i missing? It's been quite a while that I am trying to figure out what I do not do correctly.

 

Thank you for your help, 

Gervais.

 

4 REPLIES 4
V-pazhen-msft
Community Support
Community Support

@gervaisper 

You need map the power bi email account to an account that has permission to access the as server. We normally use Domain/Username format instead of Email format to connect AS.

Manage your data source - Analysis Services - Power BI | Microsoft Docs

 

 

Paul Zheng _ Community Support Team
Best Regards

Hi Paul,

I did the mapping has you explain in your post.

I am able to connect to my SSAS server with my account Domain\Username when using SSMS.

When I verify the log of the on-premise data gateway, my doman\username is passed correctly in the connection string. 

Still having the problem!

Thanks for your post.

G.

 

FarhanAhmed
Super User
Super User

Did you check the below document?

 

Manage your data source - Analysis Services - Power BI | Microsoft Docs







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




Hi FarhamAhmed,

Thanks for your response. I appreciate.

 

Yes I did. I verified every aspect included in this article, listen to both video. 

 

I also change the Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.dll.config file

to set the ADUserNameLookupProperty and the ADUserNameReplacementProperty with my email-UPN has describe in the document without any success. The only thing I did not do is to set a value for the ADServerPath. Since the AD name resolution is running, I do not think it has any effect with my problem.

 

Any help will be welcome.

 

Have a good day.

Gervais.

 

Helpful resources

Announcements
Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!

Top Kudoed Authors