cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
henrik_nordling
Frequent Visitor

On-prem data GW keeps creating junk files on C-drive

After installing a new PBI On-prem data GW 14.16.6549.2 junk files and folder a created on the C-drive

Example of folders names:

+360YjLX+XPUzmDSeJ+tr8t3XOXDiJvuh0OYpY69Bw=

+LdWMP+iqbr+5doyd1DZiiFYd1OknhyH6F1m4YyHoo=

+LtLM+aswqVWoa85K8onvUPgm78aexj4gx9VzlwGCM=

and so on.

About 10-20 new folders are created every day, and I really have to concentrate when cleaning them out so that the windows folder among others do not get removed!

 

Within the folders, I find the exact same structure:

     Index - empty folder

     Temp - empty folder

     Cache.Key - file

 

I have two other gateway installations NOT doing this, and I cant find anything in the logs explaining why those folders are created. I know it is the GW creating them because file owner is local account "PBIEgwService".

 

Fist step would of course be to reinstall the gw but it runs a bounch data sources in a global company  with a number of credentials, so the task of re-installing is quite excensive. And so I dont really like to do it if unnessesary.

1 ACCEPTED SOLUTION

I have also installed version 14.16.6614.5 and junk folders are no longer being created. The issue has been fixed in this version.

View solution in original post

32 REPLIES 32
alexandre_rowup
Frequent Visitor

Hello srs. Im get a lastest version of PBI GW (3000.27.30 - Feb/20), and this problem (Windows Event Viewer Error ID 36882 - Source Schannel), persists.

 

We have more than one error per minute.

 

Any can help-me?

 

Thanks!

sanimesa
Post Prodigy
Post Prodigy

Just wondering if there's been an update on this. I am also experiencing the same problem, Windows 2012 server, gateway installed last Dec.

 

Also, can these files and folders be deleted without any problems? 

 

Thanks.

I submitted a support ticket for this. It is a known issue. Here is the response I received.

 

"The issue which you are facing is a known issue and the Product group team is working actively on it."

"I will update you once I get any update on it from the PG team."

 

I will post any updates I get on this issue.

Just received an update on my support ticket. This issue should be fixed in the March update.

So we can only wait 🙂
Hope it will realy be solved.

Last response from Microsoft on 27th of feb.

>>I would like to inform you that the latest gateway is not yet released, we are expecting the ETA would be this week .  I will keep you posted with the status.

 

 

Dont think the update is released yet though...

Anonymous
Not applicable

I installed the version which is currently available for download (14.16.6614.5) and this solved the problem with the folders generated on the C-drive!

I have also installed version 14.16.6614.5 and junk folders are no longer being created. The issue has been fixed in this version.

We upgraded the on prem gateway and the junk file problem was fixed. Thanks everyone. 

arthastic
Advocate I
Advocate I

I have the same problem. Does anyone from MS Team working on this problem?

jhills
Advocate I
Advocate I

I am experiencing the same issue.

 

I checked and PBIEgwSerice has permissions to create but not to delete in the root of the C drive. I think that is why folders are being created and not cleaned up. But should it be using the root of C to store refresh cache data? Does anyone know where the path for storing refresh cache data is at? Registry entry? Config file? Wondering if that was corrupted during the install maybe.

 

Are others with this issue running the service under PBIEgwService or a different user? And does that user have permission to delete in the root of the C drive?

That sounds like a good insight because this started for me some days after I upgraded the gateway on the server and changed from a AD-user to PBIEgwService on the service.

 

I'm going to move the gateway to a new server, not sure whether I'm going to run it as the PBIEgwService or an AD-user. I'll let you know the result anyway.

The problem still persist after moving the gateway to a new server. This time installing version 14.16.6549.2

When I first saw that happened I reset the password for PBIEgwService and next decided to change default account.
I have created new AD account and setup the service to use it.

It changed anything 😞
Folders are still created on C drive.

Ok, that´s god information. Have to tried also granting the active directory account full permission on C-drive to see if it deletes the folders?

Dont think that is a good solution, but would be really good to know...

Granting Full acces right to account that is used for Gateway helps nothing.

Folders are creating too 😞

 

Hello, Power BI Team, please give us feedback that You are working on this issue !!!

We have same issue. Is there a option to set different cache folder and not C directly ?

karlstrom
Regular Visitor

Can a moderator PLEASE respond to this thread as it's still a problem for us.

I have created "New  Idea" in issues, please support it 🙂
Idea to SUPPORT 🙂

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show episode 9

The Power BI Community Show

Watch the playback when Priya Sathy and Charles Webb discuss Datamarts! Kelly also shares Power BI Community updates.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!