cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amitchauhan Frequent Visitor
Frequent Visitor

Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

Hi All

 

I am had a sharepoint 2010 list connected in power BI and was working fine. Not sure what changed but now the refresh wont happen. it gives me error OLE DB or ODBC error: [DataFormat.Error] OData: The format 'application/json;charset=utf-8' is not Supported. I have tried below things but its still not working.

 

1. Deleting the credentials. Even deleted the global permissions.

2. tried connecting to other list in the same site in new file and it works.

3. tried the list in problem in a new file and it still doenst refresh.

4. I am using 64 Bit Power BI.

 

Thanks

Amit Chauhan

 

8 REPLIES 8
GIS_powerBI Frequent Visitor
Frequent Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

I'm having the same issue right now. It is weird because my other dashboard already is connected and refreshing just fine. However when I try to reconnect in a new file, I get this error. Don't understand it. I tried deleting some columns to mess around with it to see if it was an issue with one of my fields. No luck so far.

Pixidilious Frequent Visitor
Frequent Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

I'm having the same issue on SharePoint 2013.

 

Connecting via OData.

 

When I select the list I want, the preview pane shows the first row of data fine, but the second row of data has the word 'Error' in every column.

 

The list has calculated and lookup columns.

 

If you click load anyway:

 

Failed to save modifications to the server. Error returned: 'OLE DB or ODBC error:[DataFormat.Error] OData: The format 'application/json;charset=utf-8' is not supported.. OLE DB or ODBC error: Exception from HRESULT: 0x80040E4E. ".

GIS_powerBI Frequent Visitor
Frequent Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

yeah mine does the same thing. loads the first row and second row is error. I also have workflows built into my SP site.

ayup Regular Visitor
Regular Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

Hi All

 

I have also encountered the same error when trying to consume data from a SharePoint list.  After some investigation, I believe that the problem may be related to an error being raised by SharePoint rather than residing in Power BI.

 

To diagnose the issue, I enabled tracing in my report:

 

File > Options > Diagnostics > Enable Tracing

 

I then tried to refresh my report data, which resulted in the utf-8 error.

 

I then accessed the trace file that was created:

 

File > Options > Diagnostics > Open crash dump/traces folder

 

Close to the end of the "Microsoft.Mashup.Container.NetFX40.<system generated id>.txt" file, I located the request that had been sent to SharePoint.  I've generalised this below to remove my company specific data:

 

http://<mysharepointsite.com>/workareap/<myworkarea>/_vti_bin/ListData.svc/Actions?$select=Column1,Column2,Column3,etc

 

I copy/pasted this request into a browser and examined the resultant response that was returned by SharePoint.  I found that an incomplete XML document was displayed that contained a number of data records but was terminated by the following error section:

 

  <m:error>
    <m:code></m:code>
    <m:message xml:lang="en-AU">An error occurred while processing this request.</m:message>
  </m:error>

 

 The initial "<feed ...>"  tag was not ended with a corresponding </feed> tag.

 

As such, I believe that Power BI doesn't handle this very well, which results in the "utf-8" error being displayed.

 

I am currently trying to pursue with our IT people to determine what error is actually being raised by SharePoint.  As such, I don't yet have a resolution to this problem.  However, I thought it worth posting this information as others who have encountered the same error may be able to follow similar steps to those I have taken and may have better access to what's going on inside SharePoint.

ayup Regular Visitor
Regular Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

Just one other thing to note regarding my particular report.  I found that I was able to access all data in my SharePoint list when using preview to scroll through all records in the Power Query Editor window.  However, when applying the query or using "Refresh" the "utf-8" error was raised.

dailiop Frequent Visitor
Frequent Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

I have the same issue when I apply the query.  The weired thing is when I tried to connect to other SP site in our company it works, but in other site in other server does not work.

dailiop Frequent Visitor
Frequent Visitor

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

I have the same issue when I apply the query.  The weird thing is when I tried to connect to other SP site in our company it works, but in other site in other server does not work.

hay0601 New Member
New Member

Re: Not able to Refresh from Sharepoint 2010 site 'application/json;charset=utf-8' is not supported

I am also having the same issue. Has anybody been able to solve this? I've seen a few threads but no solutions.