cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DOQR
Regular Visitor

Mysql connector (8.0.29) and gateway not working.

Good day,

After updating mysql connector to version 8.0.29, gateway connection stopped working.

 

Error mesage: We were unable to find a database provider with invariant name 'MySql.Data.MySqlClient'. This error could've been the result of provider-specific client software being required, but missing on this computer. To download client software for this provider, visit the following site and choose the 64-bit (x64) version of, at minimum, 'MySQL Connector/Net': https://go.microsoft.com/fwlink/?LinkId=278885

 

However, in this site have no 64bit version.

1 ACCEPTED SOLUTION
qwepoiurfn
Regular Visitor

I downgraded to 8.0.28, and then it worked!! 

I have a 64 bit server, but installed the X86 version. I saw somewhere that it is built with "Any platform", so it doesn't matter. It's .NET, so it runs on the CLR, I don't think the bits are very relevant actually, since the .NET platform itself will be 64 bit.

View solution in original post

9 REPLIES 9
v-caitlyn-mstf
Community Support
Community Support

Hi @DOQR ,

 

Glad you solved the problem, can you accept the correct answer provided by the user as a solution, so that other users with similar experience as yours can find the answer quickly, thanks in advance.

 

Best Regards,
Community Support Team _ Caitlyn

JaneLHunt
Advocate I
Advocate I

Thanks @DOQR,.

This is to confirm that the latest MySQL .Net Connector for Windows 8.0.29 does not work with the Power BI Service.   When trying to connect via a Power BI Gateway Server, it threw the error message:
An error happened while reading data from the provider: 'Character set 'utf8mb3' is not supported by .Net Framework.

I installed previous version of MySQL .net connector 8.0.28 on the Gateway Server and the connection worked fine.

 

Link to archived MySQL .net connector for Windows. 

Glad I found this post! I was going a bit crazy trying to work out what was wrong - as above installed  8.0.28 - rebooted server and worked with no issues.

 

 

qwepoiurfn
Regular Visitor

I downgraded to 8.0.28, and then it worked!! 

I have a 64 bit server, but installed the X86 version. I saw somewhere that it is built with "Any platform", so it doesn't matter. It's .NET, so it runs on the CLR, I don't think the bits are very relevant actually, since the .NET platform itself will be 64 bit.

Hey everyone, 

I tried it too, but to no avail. Do you have any other suggestions? 

I have a database behind a SSH but the connection is stable and working. 

I removed all versions of MySQL installed 8.0.28, 27, 16, 17, 18 none of these worked for me. I always installed the bench, shell and the connector.  With 8.0.28 I am getting the error message: MySQL: Reading from the stream has failed.

 

I am running out of ideas to be honest. 

Does downgrading mean uninstalling the newer and installing the older? Do I need to backup config or anything?

I will answer myself. Uninstall new, re-install old seems to work, no issues.

I installed version 8.0.28 and it worked again! Really no matter the x86 version worked normally.

Glad that it worked! 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Kudoed Authors