cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Issues with Power BI Report Server

Hello,

I just recently installed the Power BI Report Server.  It's been working well so far creating and uploading reports.  The subscription part is currently an issue when I try to schedule a report ( Subscription ).  I'm getting the following error when I run now.  Also tried to edit the schedule, but it does not run at the given date and time I selected.  Can you someone help me get the root cause on this issue ?  Any help will be appreciated.  

 

2019-09-03_17-10-42.jpg

Thanks,

Joe

1 ACCEPTED SOLUTION

Accepted Solutions

If you go into the folder "C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer"

and open the rsreportserver.config file you will find a setting called <SMTPUseSSL> I think this defaults to true. 

 

If you are sending email via an internal smtp server then either it's SSL certificate is not valid or maybe it's not setup to use SSL. If it's not setup to use SSL, but it's not accessible via the internet then maybe it's OK to change this setting to <SMTPUseSSL>False</SMTPUseSSL>. If should be able to find out from you IT department if the smtp server is configured for SSL connections or not.

 

ps. I think you will have to stop and re-start PBIRS using the configuration tool for this setting to take effect.

View solution in original post

6 REPLIES 6
Super User II
Super User II

You'll need to check the log files on your server. If you have installed to the default location you will find these in the following folder

C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles

 

Hopefully you will find a more detailed error in the most recent log file starting with "ReportingServicesService" (this is the service that processes subscriptions)

I'm getting this error in the log file. 2019-09-04_8-22-39.jpg

 

2019-09-04_8-25-30.jpg

Can someone please help on this error for the email subscription in report server ? 

emailextension!WindowsService_0!3980!09/05/2019-00:12:09:: e ERROR: Error sending email. Exception: System.AggregateException: One or more errors occurred. ---> System.Net.Mail.SmtpException: Failure sending mail. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)
--- End of inner exception stack trace ---
--- End of inner exception stack trace ---
at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
at System.Threading.Tasks.Task.Wait(TimeSpan timeout)
at Microsoft.ReportingServices.EmailDeliveryProvider.EmailProvider.Deliver(Notification notification)
---> (Inner Exception #0) System.Net.Mail.SmtpException: Failure sending mail. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)
--- End of inner exception stack trace ---<---

If you go into the folder "C:\Program Files\Microsoft Power BI Report Server\PBIRS\ReportServer"

and open the rsreportserver.config file you will find a setting called <SMTPUseSSL> I think this defaults to true. 

 

If you are sending email via an internal smtp server then either it's SSL certificate is not valid or maybe it's not setup to use SSL. If it's not setup to use SSL, but it's not accessible via the internet then maybe it's OK to change this setting to <SMTPUseSSL>False</SMTPUseSSL>. If should be able to find out from you IT department if the smtp server is configured for SSL connections or not.

 

ps. I think you will have to stop and re-start PBIRS using the configuration tool for this setting to take effect.

View solution in original post

@d_gosbell You are the man sir! This worked like a charm.  Though If I need to stop/start PBIRS again, in which I already did, the config file went back to "True".  Any feedback on this ? 


@jamezcua9 wrote:

Though If I need to stop/start PBIRS again, in which I already did, the config file went back to "True".  Any feedback on this ? 


No, we have this configured on a couple of our PBIRS instances and I have not seen this setting change after a restart. Are you definitely editing the rsreportserver.config file? This is the master config file and it writes certain settings out to other config files used by PBIRS (there are about 4-5 sub-services that make up PBIRS)

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.