cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gianluca88
Resolver I
Resolver I

Issues with API Call (Web Source) in HTTPS on report Server

Hi all,

 

when I tried to test connection on Report Server for an API HTTPS the error in the below image occurs. I underline that the same issue DOES NOT happen in Power Bi Desktop for Report Server. Could you have any suggestion?

thanks,

g.

Gianluca88_0-1668697141535.png

 

1 ACCEPTED SOLUTION
d_gosbell
Super User
Super User

Is this an internal web server that you are hitting? One possible explanation is that your client PC has a root certificate installed from an internal Certificate Authority which is not installed on the Report Server machine. Your IT department should be able to help if this is the case.

 

You could also try check the RSPortal* and ReportingServicesService* log files (usually found at C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles) to see if there are more details about this error in either of them.

View solution in original post

5 REPLIES 5
d_gosbell
Super User
Super User

Is this an internal web server that you are hitting? One possible explanation is that your client PC has a root certificate installed from an internal Certificate Authority which is not installed on the Report Server machine. Your IT department should be able to help if this is the case.

 

You could also try check the RSPortal* and ReportingServicesService* log files (usually found at C:\Program Files\Microsoft Power BI Report Server\PBIRS\LogFiles) to see if there are more details about this error in either of them.

Hi @d_gosbell ,

 

thanks for your response. It turns out to be enough to install the certificate in the machine , following for example the following link Import and Export Certificate - Microsoft Windows :: Import and Export Certificate - Microsoft Windo...

 

Thanks again,

g.

v-binbinyu-msft
Community Support
Community Support

Hi @Gianluca88 ,

Please try below steps:

Clear the Secure Sockets Layer (SSL) state. To do this, follow these steps:

  1. In Internet Explorer, click Tools, and then click Internet Options.
  2. Click the Content tab, and then click Clear SSL state.

 

Best regards,
Community Support Team_ Binbin Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-binbinyu-msft ,

thanks for your reply. Unfortunately this trick does not work. I changed Internet Option and then restarted browser on the machine where report server is installed, but with no avail. The very strange thing is that the same API call does work when I call if from the same browser (obviously with the appropriate certificate installed), but it does not work when I perform the call inside the report server. Any other suggestion? Could you recommend raising a support /bug ticket to Microsoft?

 

Thanks,

g

 

Hi @v-binbinyu-msft ,

 

coudl you help me with this topic?

 

Many thanks,

g

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.