cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jderouck
New Member

Image not showing in Power BI Report

Hi,

 

we are using the on-premise version of Report Services.

In some of our reports, we are using images, however they are not being displayed when we upload the report onto the server.

 

We are loading the images through the image button in PowerBI Desktop and have tried png, jpeg and giff. None is working.

 

Does anyone know how we can include images into our reports?

 

Kind regards,

 

Joachim

17 REPLIES 17
claudia_subia
Regular Visitor

I have now the same issue! I can not display any embeded image in the power bi report when it is published as a public url.

 

When you say published as a public URL, are you publishing this to the Power BI service or Power BI Report Server?  

Hi Chris,

 

Can you please let me know if I push from power bi desktop, the reportis published under 

Power BI service or Power BI Report Server.

 

And I am facing same immage issue what is your suggestion.

 

Thanks for your help.

powerbi.PNG

I have the problem when I publish to web with this public url.

claudia_subia
Regular Visitor

I have the same problem now! I can not display any embeded image inside my reports. 

johncpratt
Advocate II
Advocate II

I just installed the latest release (as of 9/11/17) of Power BI Report Server yesterday on my SQL Server 2016 Enterprise test server (I cannot find any place in the software/install that gives the exact version #, and I cannot connect to the PBIRS instance through SSMS to get a version #, but I believe it is the August 2017 Preview). 

 

PNG images are not rendering.  JPG images work fine.  Those are the only 2 formats I am using.

 

The images are stored in a folder under Report Manager, and have always worked fine with SSRS (2008 - 2016).  They are rendered at runtime using a URL in the report (ex.  =Globals!ReportServerUrl & "?/Images/CREC_Expert_Logo.png").

 

The issue happens in IE 11, Chrome with IE Tab add-in, and Chrome straight up.

johncpratt you can always check the version in the question mark icon , about.

Regarding the images you seem to be talking about paginated reports not Power BI which was the initial topic of the thread.

We will investigate it, do you have a simple repro at hand that we can use?

 

 

 

Thanks for the clarification, jtarquino.  I read the "on-premises Reporting Services" part and thought the issue was about the Report Server side.  I can post separately regarding paginated reports.  I do not have a generic repro, but will work on one if that will help.

stpnet
Impactful Individual
Impactful Individual

The issue I am having is inside PBIX reports!

 

I have a very simple PBIX file which just has a data connection in it (no grids or visualisations and several different image files (JPG, PNG, TIF, BMP, GIF) none of which seem to display

 

Interestingly if I set the background colour of the images these show up as coloured squares. Its just not pulling the actual image in

 

I can happily send the file.

Hi @stpnet.  I got an answer about my issue with paginated reports not showing PNG specifically (PNG images not displaying in paginated reports using PBIRS Aug 17 Preview).  It had to do with adding PNG to the list of trusted file formats in the ReportServer DB, ConfigurationInfo table, TrustedFileFormat key.

 

It got me thinking that your issue sounds alot like either a permissions issue accessing the images, or maybe something isn't right with your TrustedFileFormat setting (e.g. blank/missing extensions, or the report cannot access the list of trusted images at runtime).

 

I hope my issue can help you with yours, especially since I'm embedding logo images in my reports through Power BI Desktop and will hopefully be deploying them to the server soon.

stpnet can you check the version of your server, it should be at least 14.0.600.301

I just tried the scenario with this simple image like the one below and works as expected, let me know if you have additional details I can try

image.png

stpnet
Impactful Individual
Impactful Individual

Version 14.0.600.301 (June 2017)

 

Upgraded using the patch post release from an original GA install.

 

 

Could you provide one of the images you are using or the report 

Also did you clear out the cache of your browser after the upgrade? 

 

Dear,
Sorry I replying to old discussion...
I am using Simple image to display image.
Sometimes I able to See the properly on Power Bi Service and sometime not.
Interesting point is, the report access by more than 200 colleagues across globe.
The random people found the issue to see the image.

Could not find the logic.

It is very use full if any one able to help.

 

 

 

 

This problem is back!!! 

 

 

 

jtarquino
Microsoft
Microsoft

We have released and update addressing the image issue , please download the latest version from https://aka.ms/pbireportserver.

 

The full set of changes is detailed here https://powerbi.microsoft.com/en-us/documentation/reportserver-changelog/

stpnet
Impactful Individual
Impactful Individual

This seems to work fine when using IE but the images are still missing when viewed via Chrome and Safari.

 

 

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Power BI Dev Camp Session 27

Ted's Dev Camp

This session walks through creating a new Azure AD B2C tenant and configuring it with user flows and custom policies.

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.