cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
eMarcel Frequent Visitor
Frequent Visitor

Distributed Deployment: Something went wrong. Please try again later when opening report

Hi,

 

We use AuthenticationTypes: RSWindowsNTLM.

Users are facing this error when connecting from Windows workstations, NTLM works fine. There is no issue on Macs.

 

Here is our setup:

1. Reverse Proxy on top of two nodes:

2. Node1 is running SQL Server DB and Reporting Server PBIRS instance

3. Node2 is running Reporting Server PBIRS instance and connects to database running on Node1.

 

We are facing this terrible error "Something went wrong. Please try again later" when we keep PBIRS on both nodes started.

 

Problem doesn't appear when we shutdown one of the PBIRS instances, regardless of node. 

 

How can we troubleshoot this error?

 

1 ACCEPTED SOLUTION

Accepted Solutions
eMarcel Frequent Visitor
Frequent Visitor

Re: Distributed Deployment: Something went wrong. Please try again later when opening report

Thanks for pointing this out, for the time being I resolved the issue by reinstalling Power BI software on both nodes. 

Right now we are running May-2019 release.

 

 

View solution in original post

2 REPLIES 2
Super User
Super User

Re: Distributed Deployment: Something went wrong. Please try again later when opening report

I assume by reverse proxy that this is some sort of load balancer?

 

If so, did you follow all the documented steps for configuring PBIRS in a load balancer scenario (see https://docs.microsoft.com/en-us/sql/reporting-services/report-server/configure-a-report-server-on-a...)

 

Specifically check the BackConnectionHostNames settings. If you don't have that set then requests between the various components of PBIRS can "jump" across nodes which causes issues with many operations such as publishing reports.

eMarcel Frequent Visitor
Frequent Visitor

Re: Distributed Deployment: Something went wrong. Please try again later when opening report

Thanks for pointing this out, for the time being I resolved the issue by reinstalling Power BI software on both nodes. 

Right now we are running May-2019 release.

 

 

View solution in original post

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (2,371)