cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Alienvolm
Helper III
Helper III

Different values between dynamic report and paginated report

Hello, 

 

I'm having a hard time understanding why I see different results in the dynamic (Power BI desktop) report and in the Paginated report for the same measure. 

 

This is the matrix that I have created as a reference for my calculations: 

Alienvolm_0-1620317005084.png

The User % sums up to 100% for any row, which is what I wanted. This is the code I used: 

Alienvolm_1-1620317093332.png

 

In the paginated report created from the same dataset, this is my matrix:

Alienvolm_2-1620317161178.png

The first probnlem I found was that somehow whenever I run the report, I find SUM([User_]) in the % field, which I removed manually. But even then, the User % value shows 100% for all columns:

Alienvolm_3-1620317399528.png

 

Any idea of why this is happening? 

 

Thanks in advance! 

 

 

 

 

1 ACCEPTED SOLUTION
Alienvolm
Helper III
Helper III

Update: 

 

I haven't found a fix for the DAX formula, but I have decided in the end to calculate the % with an expression in the Report Builder:

 

Alienvolm_1-1620395321559.png

 

 

Now my table looks like this: 

 

Alienvolm_0-1620391176242.png

 

 

View solution in original post

3 REPLIES 3
V-pazhen-msft
Community Support
Community Support

@Alienvolm 

Thanks for sharing😊.

 

Paul Zheng _ Community Support Team

Alienvolm
Helper III
Helper III

Update: 

 

I haven't found a fix for the DAX formula, but I have decided in the end to calculate the % with an expression in the Report Builder:

 

Alienvolm_1-1620395321559.png

 

 

Now my table looks like this: 

 

Alienvolm_0-1620391176242.png

 

 

View solution in original post

Alienvolm
Helper III
Helper III

So... I made a bit of progress, as the issue seems to be that ALLSELECTED doesn't work in the paginated report. I substituted it with ALLEXCEPT (which is not my strong suite):

 

Alienvolm_0-1620330545804.png

 

 

 

Now my problem is that, while the % is correct for those rows/columns where there is a value, where there are blanks, it replicates a random result from another row:

 

Alienvolm_1-1620330639824.png

 

How do I fix this?

 

Helpful resources

Announcements
MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Urdu Hindi D365 Bootcamp 768x460.png

Urdu Hindi D365 Bootcamp

Dont miss our very own April Dunnam’s The Developer Guide to the Galaxy! Find out what the Power Platform has to offer for the traditional developer.