cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
PAWBI5 Frequent Visitor
Frequent Visitor

Custom Visual - Tachometer showing old Number on Report Server Only

Hello,

 

We are currently using Power BI Desktop and publishhing to the web.

We just installed our Power BI Report Server last night.

I am moving my 1st report from Web to Power BI Report Server.

 

I have a custom Visual called Tachometer in a Power BI Dashboard.

This was created using the Power BI Desktop [Version: 2.53.4954.621 64-bit (December 2017)]

 

I am using the Power BI Desktop RS [Version: 2.51.4885.1423 64-bit (October 2017)]  to match my Power BI Report Server.

 

Both look like this in Power BI Desktop for Web & Power BI Desktop for Report Server. And after publishing to Web, looks same.

Tachometer Correct.png

 

However, when I put it on the new Power BI Report Server, it reverts to wrong calculation, I can get this Percent

by changing the 'Callout Percent' from Target (correct) to End Value (incorrect).

Tachometer Problem.png

 

Any reason why the Report Server cannot show the 31% even though the desktop shows the correct value?

 

PAW

1 ACCEPTED SOLUTION

Accepted Solutions
PAWBI5 Frequent Visitor
Frequent Visitor

Re: Custom Visual - Tachometer showing old Number on Report Server Only

Well, not what I expected.

 

The answer was I had Tachometer.2.0.1.0.pbiviz in Report Server, and Tachometer.3.0.1.0.pbiviz for my web one.

 

I have successfully updated my Tachometer to the latest version from the store found here:

Power BI store

 

Now both work.

 

Cheers,

PAW

View solution in original post

3 REPLIES 3
Microsoft v-yulgu-msft
Microsoft

Re: Custom Visual - Tachometer showing old Number on Report Server Only

Hi @PAWBI5,

 

In my test, I did get the same result in Power BI Desktop (December 2017), Power BI Desktop RS (October 2017), Power BI service and Power BI report servre. 

 

Did you make any changeor filter on Power BI Report Server which might returned different result? Please try to directly upload .pbix file from web portal to see whether it can show correct value.

 

If possible, share your .pbix file so that I can publish it to my report server for a test.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
PAWBI5 Frequent Visitor
Frequent Visitor

Re: Custom Visual - Tachometer showing old Number on Report Server Only

Yuliana,

 

I cannot share, as the info is sensitive, however,

I am going to do a simple test.

 

I will make a new dashboard using only this Widget with some new data.

 

I will create in both versions of Power BI, publish to both Web & report server and see what happens.

 

Let you know soon.

 

Cheers,

 

PAW

PAWBI5 Frequent Visitor
Frequent Visitor

Re: Custom Visual - Tachometer showing old Number on Report Server Only

Well, not what I expected.

 

The answer was I had Tachometer.2.0.1.0.pbiviz in Report Server, and Tachometer.3.0.1.0.pbiviz for my web one.

 

I have successfully updated my Tachometer to the latest version from the store found here:

Power BI store

 

Now both work.

 

Cheers,

PAW

View solution in original post

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (3,907)