cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Marcin_PL
Frequent Visitor

Creating connection in model...

Hello,

 

I've observed a small but awkward and confusing change when refreshing data in Power BI Desktop September 2021.

After clicking "refresh" I get "Evaluating..." and "Waiting.." statuses like before for some time, but after that all sources have "Creating connection in model" for the whole time of downloading data to the model and the next status is just a confirmation sign. Of course, I have observed this on data sources which need more than a few seconds to download:)

 

Marcin_PL_0-1637854876288.png

Marcin_PL_1-1637855459198.png

 

 

Before upgrading to September 2021 version, after "Creating connection in model" status it was another with information how much rows is already downloaded and the number of rows was updated every second. It was very helpful because it was possible to estimate how much time I need to refresh whole data. Now, it is impossible.

Moreover, when the connection really can't be created (for example because of high CPU % in SQL Server or some other blocking sessions in the database) developer can not realize if he has to do something or just wait..

 

Has someone observed the same? Is it a bug? or maybe it can be somehow changed in Options?

 

Regards,

Marcin

 

 

1 ACCEPTED SOLUTION
d_gosbell
Super User
Super User


@Marcin_PL wrote:

Has someone observed the same? Is it a bug? 


This a bug with the status reporting in the Sept 2021 release that has been raised a number of times on this forum. I believe Microsoft are looking to fix this, but I'm not sure when it's planned to be released. Worst case I hope this would at least be fixed in the next major release (January 2022)

View solution in original post

5 REPLIES 5
FSmyth
New Member

Hi @Burningsuit this is the issue in power bi desktop when undertaking a refresh the data shows a constant creating connections in the model

Hi @FSmyth 

It looks like it could be. Getting data out of Sharepoint is notoriously slow. It could be that if you just wait at "creating connection in model" it will evenually return. It's going to depend on the amount of Data you have to import and the speed of the server providing it. 

You should check the Issues forum here:
https://community.powerbi.com/t5/Issues/idb-p/Issues
To see if anyone else has raised the issue and if it is not there, then you could post it.
Alternatively if you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".

Hope this helps

Stuart

d_gosbell
Super User
Super User


@Marcin_PL wrote:

Has someone observed the same? Is it a bug? 


This a bug with the status reporting in the Sept 2021 release that has been raised a number of times on this forum. I believe Microsoft are looking to fix this, but I'm not sure when it's planned to be released. Worst case I hope this would at least be fixed in the next major release (January 2022)

View solution in original post

hi, i am having issues refreshing the model. I am getting a message of "creating connection in model," timeout issues.

 

this was working previously, however, there are issues when linking now to a sharepoint location.

 

kind regards,

 

peter

Thanks for the confirmation.

 

Marcin

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Power BI December 2021 Update_carousel 768x460.jpg

Check it Out!

Click here to read more about the December 2021 Updates!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Jan 2022 Dev Camp 768x460 copy.png

Power BI Dev Camp- January 27th, 2022

Mark your calendars and join us for our next Power BI Dev Camp!