cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sebra
New Member

Cannot upload PBIX file on fresh install of PBIRS

Hi,

we recently aquired a separate testing environment for our project, so we installed a new VM with SQL Server 2017 (same as production) but as developer edition (not sure if relevant). On it we installed Power BI Report Server 15.0.1103.232 x64. We configured a service account from our domain, configured the web service url and database. The portal works fine, but as soon as we tried to upload our pbix files from the other environment or even simple dummy files we always get the same error:

(translated) Error uploading the PBIX file. Check if the file is damaged and if the extension matches the content of the file.

(german original) Fehler beim Hochladen Ihrer PBIX-Datei. Überprüfen Sie, ob die Datei beschädigt ist, und stellen Sie sicher, dass die Dateierweiterung dem Format der Datei entspricht.

 

If I check the browser developer tools I see that a request to a service fails with HTTP 422 (Unprocessable Entity)

Name Protocol Method Result Content type Received Time Initiator

http://[servername removed]/reports/api/v2.0/catalogitems HTTP POST 422 application/json 235 B 55,55 ms

 

The same happens if I try to upload through Power BI Desktop (the Report Server Version 2.81.5831.1181 x64, as downloaded from the portal-site) but with different error message: An error occured while attempting to save the report to Power BI Report Server.

 

The Portal-Logfile shows a "forbidden" error:

2020-09-11 13:16:36.3110|INFO|64|Received request GET /api/v2.0/System/Properties| RequestID = s_539fdc5e-b610-4eb4-82d8-1229ee540610
2020-09-11 13:16:36.3110|INFO|64|Sending response. Response code [removed user name] 200, Elapsed time 0:00:00.0063115| RequestID = s_539fdc5e-b610-4eb4-82d8-1229ee540610
2020-09-11 13:16:36.6408|INFO|64|Received request GET /api/v2.0/me| RequestID = s_0e1e4a8d-f940-4dcb-8997-17eb4cbe2d9a
2020-09-11 13:16:36.6720|INFO|64|Sending response. Response code [removed user name] 200, Elapsed time 0:00:00.0289183| RequestID = s_0e1e4a8d-f940-4dcb-8997-17eb4cbe2d9a
2020-09-11 13:16:36.7502|INFO|64|Received request POST /api/v2.0/powerbireports(Path='/sample')/Model.Upload| RequestID = s_a1f0ea50-22a6-4ee7-b109-918fd408f22c
2020-09-11 13:16:36.8127|ERROR|65|The remote server returned an error: (403) Forbidden.| RequestID = s_a1f0ea50-22a6-4ee7-b109-918fd408f22c
2020-09-11 13:16:36.8127|INFO|67|Sending response. Response code [removed user name] 422, Elapsed time 0:00:00.0611536| RequestID = s_a1f0ea50-22a6-4ee7-b109-918fd408f22c

 

I know there are numerous reports to the same error, but all suggested solutions did not work and most were for older versions and I often read that the compatibility between versions is an issue, so I don't know how relevant these are to the current may 2020 version.

 

I restarted the service (and reinstalled the reportserver including deleting report databases) multiple times.
I use a domain account as service-account. I even tried granting it local admin privileges (testing environment, so...)
The portal runs (by now) without https, so it should not be certificate stuff...
The test files are small (<1mb) and can be uploaded to our production server just fine.
The command "netsh http show urlacl" shows my site registration correctly.

 

I am really out of ideas what I can do and "msdn subscriber" support pointed me here... I hope anyone of you does 😄

 

Best regards 

Sebastian

3 REPLIES 3
Sebran
New Member

Thank your for your responses (even though they did not work), somehow my old profile got broken, so I could not reply anymore. I made a new one and with some official support the problem was identified: Somehow our organisation has a policy, that only accepts full qualified domain names in URIs. In the default configuration, the web gets registered to only the servername. So even if I could open the portal with FQDN in the browser, there were probably some internal links that pointed to the unqualified name. After setting the host header name in the advanced settings in the report server configuration manager, the errors were gone and everything works fine now.

FarhanAhmed
Super User II
Super User II

There are 2 versions used while deploying reports in Power BI Report Server

 

1- Server itself....

2- Designer or (Desktop Version)

 

If the Server is the latest version and the Desktop is old then you can upload the file in it

If the Server is an older version and the desktop is the latest one then you cannot upload the file in PBIRS.

 

Check PBIRS Version by clicking " ? " and "About Power BI Report Server" and see if you have the latest server installed on it.

 

PBIRS Version.png

 

 

 

 







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




sevenhills
Continued Contributor
Continued Contributor

Hi,

 

https://docs.microsoft.com/en-us/power-bi/report-server/changelog

 

As per your thread, you are saying, you have June 15, 2020 version of PBIRS.

 

a) Please check the Power BI Desktop version installed on the server.

Note: we have to install different PBI Desktop, Power BI Desktop (optimized for Power BI Report Server)

https://www.microsoft.com/en-us/download/details.aspx?id=56723

 

b) Try uploading an image or regular .rdl report , to make sure the upload is working

      some dummy image

 

c) Client PBI Desktop has to be different for PBIRS

        Try uninstall and install by download again. both on server and client.

        Microsoft Power BI Desktop (Optimized for Power BI Report Server - May 2020)

 

Hope this helps.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!