cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mrast
New Member

Cannot save pbix or upload pbix to report server

Hi

 

Fresh install of an on prem PowerBI Report Server on Server 2019, its a test box for now so SQL also installed on same box (SQL 2019)

 

I am unable to upload pbix files through the web interface, nor am i able to save them using Save As from the Desktop application.

 

Both server and desktop client are May 2021 x64

 

When i try to upload using the web interface i get:

 

 

 

There was an error uploading your .pbix file. Verify that the file has not been corrupted and that the file extension matches the format of the file.

 

 

 

When i use the desktop client and choose Save As and then choose the PowerBI Server - i input my url and at the end i get the error:

 

 

 

An error occured while attempting to save the report to Power BI Report Server

 

 

 

Client and Server both on same domain.

 

Log file keeps showing a 401 unauthorised and a 404 not found every time i try a pbix file - however i can upload word and excel files just fine

 

 

 

2021-07-30 09:53:41.1929|INFO|55|Received request GET /api/v2.0/CatalogItems(Path='/PowerReport1.pbix')| RequestID = s_a76011a7-e009-4e31-83c7-0b0b49fb900a
2021-07-30 09:53:41.1929|ERROR|55|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/PowerReport1.pbix' cannot be found.;| RequestID = s_a76011a7-e009-4e31-83c7-0b0b49fb900a
2021-07-30 09:53:41.1929|INFO|55|Sending response. Response code domain\user 404, Elapsed time 0:00:00.0039785| RequestID = s_a76011a7-e009-4e31-83c7-0b0b49fb900a
2021-07-30 09:53:41.3336|INFO|55|Received request GET /api/v2.0/CatalogItems(Path='/PowerReport1')| RequestID = s_e3264ae6-d8e7-419f-89dc-d9544d3385b6
2021-07-30 09:53:41.3336|ERROR|55|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/PowerReport1' cannot be found.;| RequestID = s_e3264ae6-d8e7-419f-89dc-d9544d3385b6
2021-07-30 09:53:41.3336|INFO|55|Sending response. Response code domain\user 404, Elapsed time 0:00:00.0037668| RequestID = s_e3264ae6-d8e7-419f-89dc-d9544d3385b6
2021-07-30 09:53:41.7398|INFO|55|Received request GET /api/v2.0/System/Properties| RequestID = s_f2b30548-31fb-432f-9875-b47d3ab67b89
2021-07-30 09:53:41.7554|INFO|55|Sending response. Response code domain\user 200, Elapsed time 0:00:00.003992| RequestID = s_f2b30548-31fb-432f-9875-b47d3ab67b89
2021-07-30 09:53:41.9429|INFO|55|Received request GET /api/v2.0/me| RequestID = s_6e9e5018-3494-4471-9e10-09cf9f435276
2021-07-30 09:53:41.9898|INFO|55|Sending response. Response code domain\user 200, Elapsed time 0:00:00.0382069| RequestID = s_6e9e5018-3494-4471-9e10-09cf9f435276
2021-07-30 09:53:42.1304|INFO|55|Received request POST /api/v2.0/powerbireports(Path='/PowerReport1')/Model.Upload| RequestID = s_0a3fe44d-23fc-4fb7-b66d-9be5e9ab1f18
2021-07-30 09:53:42.1304|ERROR|55|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/PowerReport1' cannot be found.;| RequestID = s_0a3fe44d-23fc-4fb7-b66d-9be5e9ab1f18
2021-07-30 09:53:43.3393|ERROR|54|The remote server returned an error: (401) Unauthorized.| RequestID = s_0a3fe44d-23fc-4fb7-b66d-9be5e9ab1f18
2021-07-30 09:53:43.3393|INFO|52|Sending response. Response code domain\user 422, Elapsed time 0:00:01.2197189| RequestID = s_0a3fe44d-23fc-4fb7-b66d-9be5e9ab1f18 

 

 

Ive granted my domain account full rights to the Report Server Site Settings also in Manage Folder

 

Anybody able to offer any further help on this please?

 

Thanks

15 REPLIES 15
vivien57
Helper I
Helper I

Hello all,

Were you able to solve your problem?

I have this problem which occurred on the DEV server (not in UAT and PROD) and I would like to avoid a complete reinstallation.

I tried to assign a new ReportServer database but the problem is the same...

Thank you in advance for your feedback,

Have a nice day,

Vivien

AndrewTobin
Frequent Visitor

Hey all,

 

I have installed this on my machine too - upgraded from a Power BI from a year ago, and finally had a window in our schedule to upgrade, and I have gotten this same error.

 

I have checked the logs, and it tells me there was a timeout on the POST when I am uploading a replace copy or updating a model from the Desktop version (same version as running on the server) and I get the following trying to upload a new model:

 

2021-08-11 12:52:06.1614|INFO|985|Received request POST /api/v2.0/powerbireports(Path='/Test%20Reports/Test')/Model.Upload| RequestID = s_85650080-125a-4f1c-b634-0545342cf86a 
2021-08-11 12:52:06.1614|ERROR|985|library|Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: , Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item '/Test Reports/Test' cannot be found.;| RequestID = s_85650080-125a-4f1c-b634-0545342cf86a 
2021-08-11 12:52:06.2395|ERROR|1478|The remote server returned an error: (400) Bad Request.| RequestID = s_85650080-125a-4f1c-b634-0545342cf86a 

 

And this for updating an existing model:

2021-08-11 11:47:13.5921|INFO|2026|Connection dropped. DOMAIN\AndrewTobin 10.5.253.254: POST /api/v2.0/powerbireports(Path='/Test/Tracking')/Model.Upload, Elapsed time 0:01:39.1772844| RequestID = s_e8d2e6c8-d5c3-406c-831b-566579d97baa 
2021-08-11 11:47:40.9053|INFO|1728|Sending response. Response code DOMAIN\AndrewTobin 200, Elapsed time 0:03:40.2154128| RequestID = s_fe91f816-5794-4909-ab27-04c70527de4d 

 

One of the differences in the configuration we have is that we don't use the regular server name - we use a server alias, and we wanted that alias to appear on the outgoing emails, etc, so I have set the host on the  Web Service URL and Web Portal URL to respond to http://host:80/reports/ rather than http://machine:80/reports/

 

When I set it back to accepting "All Assigned" on IP Addresses, the uploads work fine. 

When I set my hostname as the only acceptable URL I get the errors. 

 

I have tried the May 2021 on our development server as well, to test before changing production, and it uses the "All Assigned" and worked without error.

 

This configuration worked previously, so I am unsure why updating has broken it, but any resolution you could provide would be appreciated.  And maybe OP has a similar config?

sevenhills
Super User
Super User

I saw your message that you installed the RS version of Power BI on PBIRS. It more looks server to client issues based on your info. before we decide that, let us revisit from the beginning. 

 

1. MSTSC / Remote desktop to the server (with full permissions user)

 

2. Try browsing both .rdl and .pbix. (u try with localhost and server name in the browser)

 

3. Say if either of them are NOT working, I will say, run the installation of PBIRS and make sure you configured all the steps.

     After the server setup, run the PBI RS client again on server.

     Restart (even though not needed.)

     Try (2) step above

 

4. if it is working on the server and not working on the client, then it is more of client-server issue.

 

        

 

 

 

 

 

Ok i have configured PBIRS server with local IP and server name for both Web Portal and Web Service URL

 

So i now have in both Web Portal and Web Service URL:

 

http://192.168.1.25/reports

http://servername/reports

https://url.domain.com/reports

 

Browsing them on the server itself i still cannot upload pbix files with the same error

 

There was an error uploading your .pbix file. Verify that the file has not been corrupted and that the file extension matches the format of the file.

 

Just a guess

a) Your PBIRS is not configured for .pbix; check the log files; You may need to check report configuration manager

 

b) Only Server compatible version of "Power BI Desktop" need to be installed and no other power bi desktop version. You need to check that version

Power BI Desktop for the report server

 

c) you cannot use latest version than the server installed version. Try creating the power bi file using the server installed version and then upload and then browse.

 

In other words, make sure the Power BI Desktop used for your report creation matches or less than the version installed. 

 

You can check the version of server installed server compatible power bi desktop and the version you are uploading. then you will know 

 

 

(all of the above using remote desktop and if all works, then try from client)

A little further info:

 

Trying to upload a RDL file results in a 503 Service not available error

You have to check server logs: Generic errors, it is tough to guess what is the root cause. It can be anything. http errors, windows errors, authentication errors, database connectivity errors or more ... you can need to check the server logs.

 

one thing is sure based on your thread conversation is that the server is not configured properly. either start a clean install or proceed with fixing errors, as you counter. It is upto you. 

This is the third time ive reloaded it, luckily its just a test box at the moment.

Its just a vanilla install with all the defaults bar changing the portal and service url's

 

Only errors i can see from report server logs and event logs are a combination of 401/404 with pbix files and 503 with rdl.

docx and xlsx are fine though.

 

Ill try nuke it all again and reinstall from fresh again

https://spgeeks.devoworx.com/install-and-configure-power-bi-report-server/ 

 

The link has step by step details. including 503 error.

V-pazhen-msft
Community Support
Community Support

@mrast 

 

Try right click desktop - run as admin, and remove "browse" from the url, using the below format to save the report to report server.

Vpazhenmsft_0-1627956196834.png

 

 

Paul Zheng _ Community Support Team

FarhanAhmed
Super User
Super User

Can you please make sure that you are using the correct version and using PBI Desktop Optimized for PBIRS 

 

Did you check it by restarting the services?

The error is most likely to be related with Authorization.

 







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




Yes im using the PBI Desktop Optimized.

 

Have tried the one downloaded from the PBI Server and also the one from this link

https://www.microsoft.com/en-us/download/confirmation.aspx?id=56723

 

The error does says its a 401 auth issue - but why is what i cant work out and need help with.

I can upload other files to it just not PBIX files.

Kindly refer below articles if they can help

 

http://mehsanullah.blogspot.com/2017/11/power-bi-can-not-save-report-to-server.html

https://jasonjonesdata.blogspot.com/2019/07/power-bi-report-server-error-has.html

 

 







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




Hi,

 

Had already found those 2 articles in my searching to try and resolve the problem, unfortunately neither of them help solve the issue.

 

 

 

 

Sometimes reporting database does create problem, try create a new database for PBIRS

 

by going to 

- Open Report Server Configuration

- Under Databsae Click "Change Database" and Create new one for your report server and then try upload file.







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show Episode 10 Recap

The Power BI Community Show

Watch the playback when Amit Chandak, a Power BI Super User, demos how to use Field Parameters to make reports more dynamic.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.