cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mkbytes
Regular Visitor

Cannot Publish a Pbix file

Hello,

We are running October 2020 version of PBI report server on prem. Paginated reports are currently in use, but we cannot upload a pbix report. I'm currently using the matching PBI desktop version for the report server.  I created a test file with no data sources and still recive the error "There was an error uploading your .pbix file. Verify that the file has not been corrupted and that the file extension matches the format of the file." Any suggestions?

 

Thanks in advance!

13 REPLIES 13
Anonymous
Not applicable

Thanks but same error. Can I send you logs somehow? There is no attach file button here in the community.

 

I can see in the log for the server that my user scans folders but no error when saving so I would guess it is something wrong on the client side.

Petebro
Microsoft
Microsoft

Hi I've been following up with the Desktop team. Can you try to disable the "Certificate Revocation Check" feature in the security settings of Power BI Desktop? There was a bug related to it that was fixed recently.

 

MicrosoftTeams-image.png

 

Anonymous
Not applicable

One more week has passed. Any news?

Anonymous
Not applicable

Any news about this error?

Anonymous
Not applicable

DataMashup.Trace Warning: 24579 : {"Start":"2020-11-04T10:32:51.9629674Z","Action":"PBI.FileSave","entryPoint":"EditorRibbonButtonPowerBISharePublish","size":"","unappliedQueries":"False","parentId":"4ebb1614-084b-4a30-9042-e18fbf2a7cd1","isError":"True","sessionId":"b19b2a7d-d626-48a7-8e82-aa6007d25da3","deviceId":"9ba80868","userId":"a657900e-f028-4bd5-8356-fbbdf604c574","isInternal":"False","authenticatedUserId":"Unknown","ProductVersion":"2.86.961.0 (20.10)","ActivityId":"9c0bad8c-5c53-4c8a-aadf-13c14b8f5aaa","Process":"PBIDesktop","Pid":45160,"Tid":1,"Duration":"00:00:07.0011427"}
Anonymous
Not applicable

We are having the same issue but with a different error message. Running PBRS October 2020 (upgrade from January 2020) and the accompanying client.

When I try to Save As on the PBRS I can browse the folders but when I click Save it is spinning for a second ant then I get "Server is not reachable".

 

Upload a .pbix in the browser works thugh.

 

We have not set up https on the server but I guess that is not mandatory?

Hi,

 

I'm trying to reproduce either issue and am unable to get an error publishing my report to the local reportserver with either the 64 or 32 bit version of desktop. Can you post the version of Power BI Desktop for Report Server you are using?

 

This is the expected version:

  • Version: 2.86.961.0 32-bit (October 2020)
  • Version: 2.86.961.0 64-bit (October 2020)

 

-Pete

Anonymous
Not applicable

Desktop Version: 2.86.961.0 64-bit (oktober 2020)

Server Version 1.9.7604.41261 (October 2020)

Could you look at the PBIDesktop*.log file for any error messages?

To get to the log go to the options dialog, then the diagnostics tab. There is a link to the traces folder there.

 

I'm still unable to reproduce this with the same versions (and even got a localized version of desktop thinking maybe it was related to that).

Anonymous
Not applicable

I think i found something related to the error in the log file:

 

DataMashup.Trace Warning: 24579 : {"Start":"2020-11-03T17:57:53.4940584Z","Action":"PBI.PQ.SaveDiscardInternal","actionId":"SaveDocumentInternal","entryPoint":"EditorRibbonButtonPowerBISharePublish","errorCode":"ServerNotReachable","message":" at Microsoft.PowerBI.Client.Windows.SSRSService.SSRSPbixFile.<Save>d__28.MoveNext()\r\n--- End of stack trace from previous location where exception was thrown ---\r\n at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at Microsoft.PowerBI.Client.Windows.Services.FileManager.<CopyTempToFile>d__33.MoveNext()\r\n--- End of stack trace from previous location where exception was thrown ---\r\n at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at Microsoft.PowerBI.Client.Windows.Services.FileManager.<TrySaveBIPackage>d__28.MoveNext()","wasRetried":"False","retryReason":"","parentId":"3e812f42-1646-402f-8a7d-0a0917f1849d","isError":"True","sessionId":"799ac05d-4377-4271-ac85-ed4a70c77d39","deviceId":"9ba80868","userId":"a657900e-f028-4bd5-8356-fbbdf604c574","isInternal":"False","authenticatedUserId":"Unknown","ProductVersion":"2.86.961.0 (20.10)","ActivityId":"2296ae04-f5e4-43af-ade5-de2d7aec9ab2","Process":"PBIDesktop","Pid":116108,"Tid":1,"Duration":"-00:00:00.0002562"}
Anonymous
Not applicable

Maybe this can be of help as well. These lines are just above the previous line:

 

DataMashup.Trace Information: 24579 : {"Start":"2020-11-03T17:57:53.2410690Z","Action":"JsonSerializer/TryDeserialize","Result":true,"ProductVersion":"2.86.961.0 (20.10)","ActivityId":"00000000-0000-0000-0000-000000000000","Process":"PBIDesktop","Pid":116108,"Tid":1,"Duration":"00:00:00.0001546"}
DataMashup.Trace Information: 24579 : {"Start":"2020-11-03T17:57:53.3424864Z","Action":"JsonSerializer/TryDeserialize","Result":true,"ProductVersion":"2.86.961.0 (20.10)","ActivityId":"00000000-0000-0000-0000-000000000000","Process":"PBIDesktop","Pid":116108,"Tid":1,"Duration":"00:00:00.0002794"}
DataMashup.Trace Warning: 24579 : {"Start":"2020-11-03T17:57:52.9604204Z","Action":"PBI.Win.SaveReportToSSRS","result":"ServerNotReachable","parentId":"3e812f42-1646-402f-8a7d-0a0917f1849d","isError":"True","sessionId":"799ac05d-4377-4271-ac85-ed4a70c77d39","deviceId":"9ba80868","userId":"a657900e-f028-4bd5-8356-fbbdf604c574","isInternal":"False","authenticatedUserId":"Unknown","ProductVersion":"2.86.961.0 (20.10)","ActivityId":"e544a76c-8bef-4b89-9183-c7ed7430ba71","Process":"PBIDesktop","Pid":116108,"Tid":1,"Duration":"00:00:00.5262420"}

The part where it says  "authenticatedUserId":"Unknown", may have something to do with the error!?

When I run go to the Report Server web UI I always have to put in my credentials in a basic dialog. I am using the same credentials when publishing the report. But I get the feeling that our report server somehow does not pick up the AD-user when using Google Chrome.

Are you running basic, custom auth or windows authentication on the report server?

 

https://docs.microsoft.com/en-us/sql/reporting-services/security/configure-basic-authentication-on-t...

 

 

I'm guessing since you mentioned AD the answer is windows, and you're hitting an issue with your windows username not being listed explicitly in the security settings of your Report Server, but the user is an admin on the machine (and thus part of the builtin\admins group which is listed). The solution could be to explicitly list your username in a folder (or root) security tab of the report server.

 

To do this you can run chrome, edge, or IE as administrator (right click on short cut-> run as administrator) then click the "manage"  button on a folder of your Report Server, then click security and add "{Domain}\{Username}" to the list with all roles. 


 

Anonymous
Not applicable

Fifth time im replying, this community server really leavs a lot to ask for...

 

Windows auth and same error message from Desktop after putting in my usernamne with domain in the root folder on the report server (Manage Folder)

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

Thank you 2022 Review

2022 Monthly Feature Releases

We had a great 2022 with a ton of feature releases to help you drive a data culture.