cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cascador84
Frequent Visitor

Can't upload report to report server (January 2021)

Hi,

 

I'm having some issues uploading Power BI reports to Report Server. I get errors both when Saving As and when uploading from within Power BI itself.

 

The errors I'm receiving are, respectively:

 

  • Upload via Report Server: "There was an error uploading your .pbix file. Verify that the file has not been corrupted and that the file extension matches the format of the file."
  • Save As via PBI Desktop: "An error occurred while attempting to save the report to Power BI Report Server"

The versions I'm using are: january 2021 (server and client)

 

any idea ? nothing appear on log except error 400 bad request.

thanks in advance.
regards

 

1 ACCEPTED SOLUTION

Dear Benjamin

finally, on our prod server, all has been resolved with new January release.
hope it will be the case for you also.

 

View solution in original post

18 REPLIES 18
bomscik
New Member

I will upload after save file. pbix in my computer. 

after that upload again.

Petebro
Microsoft
Microsoft

Are you still having issues uploading/publishing reports to your server? This is not widely reported but I'm wondering if there is a smaller issue hiding with specifics features/data source types.

 

-Pete

Hello Pete

 

I have the same Problem with my Production Report Server. I first tried the new Update on our Test Server, all seems to work there. 

I also tried to download an existing Power BI report from the server and upload it unchanged to a new location, but i get the same Error as described by Cascador84.

We have Power BI Desktop Version 2.88.1382.0 32-bit (Januar 2021) and Report Server Version: 1.10.7698.27886 (Januar 2021)

 

regards

Benjamin

Dear Benjamin

finally, on our prod server, all has been resolved with new January release.
hope it will be the case for you also.

 

View solution in original post

Hello Cascador

 

What Version did you install oun your prod server? We have the same version on our test and prod server, but the problem only exists on our prod server. 

Thats the same Version as we have installed. 

Dear Pete,

yes, we still have issue. It concerns dev server, but for other issue on prod server, we should soon update also prod server to this version, hopping we could be able to still upload / publish power bi report

Is it every PBIX or specific ones with types of datasources/features?

all pbix

Same here at one of our clients environment - all pbix (does not matter if new or updated one) 
no differences in data sources

 

@Petebro - any ideas what we can do?

Hi @wstrasse 

 

I had the same problem, but we could solve it now. We had a special SSL Certificate on our Report Server which was for more than one URL. We now changed this to a Certificate, wich is only for our Report Server and now all works fine. 

Hope this helps you too.

Hi wstrasse

 

I have opened a support call with Microsoft, but until now we couldn't fix the problem. 

By trying different things I saw, that the problem dosen't apper, if I change the binding of the report server to http and the servername instead of an real url with https. Do you have the same behavior?

josef78
Continued Contributor
Continued Contributor

Which version you are using, new build from January 8th or new version from January 21th?

Please check id your server version is 1.10.7698.27886, and Desktop version is 2.88.1382.0 exactly.

 

Is this issue present in any case (including clean created pbix), or only for some specific files?

 

Hello Josef

yes, version are 1.10.7698.27886 (server) and Desktop version is 2.88.1382.0 exactly. This occurs for all pbix, and also the newly created.

 

on the rspowerbi log files, we have something like this when trying to upload / publish report:

2021-02-03 13:56:15.8762|INFO|4|Received request POST /api/reportproperties| RequestID = s_ae385ca0-4cfb-40c2-beee-2295067bda29
2021-02-03 13:56:15.8762|ERROR|4|HttpRequestContext returned false for IsLocal.| RequestID = s_ae385ca0-4cfb-40c2-beee-2295067bda29
2021-02-03 13:56:15.8762|INFO|4|Sending response. Response code loginusername 400, Elapsed time 0:00:00,0011676| RequestID = s_ae385ca0-4cfb-40c2-beee-2295067bda29

josef78
Continued Contributor
Continued Contributor

I don't have any idea,... but it can be related to authorisation (maybe between RSPortal and RSPowerBI). You are using ntlm or kerberos authorisation?

Also try check setting in report server configuration manager, specialy Web Service URL and Web Portal URL (there must be defined indentical servers and protocols (http vs https, and using hostname vs fqdn). 

Also check RSPortal logs (there must be related entries).

FarhanAhmed
Super User II
Super User II

A similar thread is already opened. See if this helps you.

 

https://community.powerbi.com/t5/Report-Server/Power-BI-Report-Server-October-2020-update-has-been-r...

 







Did I answer your question? Mark my post as a solution! Appreciate your Kudos!!

Proud to be a Super User!




Hello Ahmed,

thanks for reply. Yes, I see the post, and we will check for proposed solution (delete database ??? not sure this is a good idea, but why not). Moreover, we upgrade the report server from october 2020, and we were able to upload report...

 

Helpful resources

Announcements
MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Urdu Hindi D365 Bootcamp 768x460.png

Urdu Hindi D365 Bootcamp

Dont miss our very own April Dunnam’s The Developer Guide to the Galaxy! Find out what the Power Platform has to offer for the traditional developer.