cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
VegeMike
Regular Visitor

Can't turn Use a Data gateway off

Hey everyone,

 

Hoping someone here can help.  

 

I originally started my Dashboard with an Excel file while I awaited direct access to SQL.  As a result, I set up a gateway and everything was fine.

 

Fast forward to now and I have sql access, and moved all my visiualization soruces to ther sql databases.  Since I no longer need the gateway, I deleted it.  However, I can't turn it off because the option is grayed out.

powerbierror.png

 

For extra background, I had deleted the data from the Fields list (and it warned it was in use).  I then had to go query Editor and delete synch logs referring to the Excel files and was THEN able to delete the excel sources and they stopped appearing in my Options->Data Source box.

 

The bahavior SEEMS to be that Power BI thinks I am referencing these local files SOMEWHERE, so it is enforcing a gateway but I don't see where.  In the meantime, I'm gettign local accounts to add SQL to the Gateway for refresh, but I'd rather not have to use a gateway at all.

 

Any ideas?  Any ways to see what is being referred to (perhaps from these local files) and where?

 

Thanks!!!

1 ACCEPTED SOLUTION

So I figured it out.

 

Of my 3 SQL sources, 2 were Azure....1 was not.  

 

That was what required the gateway.

 

Confirmed via a test Dashboard that only had an Azure source, no gateway needed and refresh was available.  Added the non-azure source and BAM....needs a gateway!

View solution in original post

3 REPLIES 3
VegeMike
Regular Visitor

To add in, I created a brand new test file, created a dinky report, and published it.  Use Gateway is set to Off and I can change it as I please.

One more note.

 

I noticed I have this defined in 2 places:

 

My Workspace

A named workspace

 

Is that a problem?  I can certainyl delete one (both won't allow me to disable the gateway).

So I figured it out.

 

Of my 3 SQL sources, 2 were Azure....1 was not.  

 

That was what required the gateway.

 

Confirmed via a test Dashboard that only had an Azure source, no gateway needed and refresh was available.  Added the non-azure source and BAM....needs a gateway!

View solution in original post

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.