cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
VegeMike Frequent Visitor
Frequent Visitor

Can't turn Use a Data gateway off

Hey everyone,

 

Hoping someone here can help.  

 

I originally started my Dashboard with an Excel file while I awaited direct access to SQL.  As a result, I set up a gateway and everything was fine.

 

Fast forward to now and I have sql access, and moved all my visiualization soruces to ther sql databases.  Since I no longer need the gateway, I deleted it.  However, I can't turn it off because the option is grayed out.

powerbierror.png

 

For extra background, I had deleted the data from the Fields list (and it warned it was in use).  I then had to go query Editor and delete synch logs referring to the Excel files and was THEN able to delete the excel sources and they stopped appearing in my Options->Data Source box.

 

The bahavior SEEMS to be that Power BI thinks I am referencing these local files SOMEWHERE, so it is enforcing a gateway but I don't see where.  In the meantime, I'm gettign local accounts to add SQL to the Gateway for refresh, but I'd rather not have to use a gateway at all.

 

Any ideas?  Any ways to see what is being referred to (perhaps from these local files) and where?

 

Thanks!!!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VegeMike Frequent Visitor
Frequent Visitor

Re: Can't turn "Use a Data gateway" off

So I figured it out.

 

Of my 3 SQL sources, 2 were Azure....1 was not.  

 

That was what required the gateway.

 

Confirmed via a test Dashboard that only had an Azure source, no gateway needed and refresh was available.  Added the non-azure source and BAM....needs a gateway!

View solution in original post

3 REPLIES 3
VegeMike Frequent Visitor
Frequent Visitor

Re: Can't turn "Use a Data gateway" off

To add in, I created a brand new test file, created a dinky report, and published it.  Use Gateway is set to Off and I can change it as I please.

VegeMike Frequent Visitor
Frequent Visitor

Re: Can't turn "Use a Data gateway" off

One more note.

 

I noticed I have this defined in 2 places:

 

My Workspace

A named workspace

 

Is that a problem?  I can certainyl delete one (both won't allow me to disable the gateway).

Highlighted
VegeMike Frequent Visitor
Frequent Visitor

Re: Can't turn "Use a Data gateway" off

So I figured it out.

 

Of my 3 SQL sources, 2 were Azure....1 was not.  

 

That was what required the gateway.

 

Confirmed via a test Dashboard that only had an Azure source, no gateway needed and refresh was available.  Added the non-azure source and BAM....needs a gateway!

View solution in original post

Helpful resources

Announcements
Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

Power BI Desktop Update - February 2020

Power BI Desktop Update - February 2020

We are super excited for our update this month, as we are releasing two of our top community requests!

Power Platform Online Conference

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!