cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Katebrk
Helper I
Helper I

Can't connect to data source through Test connection

Hello!

I have the following situation with all of my reports on Report Server: 

1) I go to Manage -> Data sources and click "Test connection". Then the following error occurs: "The error occurs. Please try again later" and no more detailed information on number of error or what I should check. 

 

open666.png

2) I check if the refresh of the report was succesful and I see that the refresh was sucessfully completed 30min ago: 

open77.png

So I guess the connection to the data sources is fine. 

 

Could anybody please tell what could be the problem or where should I strart looking? Why "Test connection" doesn't work? 

Thank you! 

1 ACCEPTED SOLUTION
Katebrk
Helper I
Helper I

I think we got it fixed. We have changed the service account name in Configuration Manager. We had service account earlier and changed to Network connection for now, and everything seemed to work. 

 

This discussion is also helpful (the replies from emixon and jcabgz) :

https://community.powerbi.com/t5/Report-Server/Error-when-deploying-a-report-to-Power-BI-Report-Serv... 

View solution in original post

3 REPLIES 3
Katebrk
Helper I
Helper I

I think we got it fixed. We have changed the service account name in Configuration Manager. We had service account earlier and changed to Network connection for now, and everything seemed to work. 

 

This discussion is also helpful (the replies from emixon and jcabgz) :

https://community.powerbi.com/t5/Report-Server/Error-when-deploying-a-report-to-Power-BI-Report-Serv... 

View solution in original post

AbhiSSRS
Impactful Individual
Impactful Individual

Do you key in password again? Because the encrypted one you see there dsn't work for test connection unless you key in the password again.It works perfectly when accessed from report. This behaviour has existed since SSRS days and isn't an issue as long as your refresh is working fine.

Hi @AbhiSSRS , thanks for the answer! It was working earlier when I clicked "Test connection" without filling login and password again. 

I guess we found the solution to this, I'll write here 

Helpful resources

Announcements
MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Urdu Hindi D365 Bootcamp 768x460.png

Urdu Hindi D365 Bootcamp

Dont miss our very own April Dunnam’s The Developer Guide to the Galaxy! Find out what the Power Platform has to offer for the traditional developer.