Reply
Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

After a scheduled refresh the report has no data

After updating to October release of Power BI Report Server we were very excited to be able to upload reports used with imported data from SQL Server directly.

When we refresh the report with latest data in desktop then upload to the report server it renders fine and all is well.

I then setup the scheduled refresh, after the scheduled refresh happens all the data becomes blank. 

The outline of the report is there but no data is visible.

 

I then use the desktop edit the report and the data shows, I refresh on the desktop and save it to the report server and the data is visible again.

 

In the logs is shows the report is being refreshed successfully.

 

2017-11-28 02:00:01.9115|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Data Refresh.
2017-11-28 02:00:01.9428|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Retrieving PBIX AsDatabaseInfo.
2017-11-28 02:00:01.9740|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Verifying all the data sources are embedded.
2017-11-28 02:00:01.9896|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Verifying connection strings are valid.
2017-11-28 02:00:02.0521|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Streaming model to Analysis Server.
2017-11-28 02:00:05.9583|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Refreshing the model.
2017-11-28 02:00:22.4579|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Removing credentials from the model.
2017-11-28 02:00:22.7704|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Saving model to the catalog.

 

What am I doing wrong? Would appreciate any help.

 

Moderator
Posts: 9,740
Registered: ‎03-06-2016

Re: After a scheduled refresh the report has no data

Hi @markp,

 

What's your Power BI report server version? Which visual is blank after schedule refresh? 

 

Based on my test in Power BI report server version 14.0.600.437, the report contains a table visual display data fine after schedule refresh completely. In your scenario, please try another browsers to see if the visual still blank. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

Version is <Product>Microsoft Power BI Report Server Version 14.0.600.437</Product>

Have tried multiple browsers and doesnt help.

 

Moderator
Posts: 9,740
Registered: ‎03-06-2016

Re: After a scheduled refresh the report has no data

@mgmeyer@riccardomuti Do you have any idea about this issue? Thanks. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

@v-qiuyu-msft Any update on this?

Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

This issue is still present even after updating to version:

<Product>Report Server Version 2017.0140.0600.438 ((BI_Server_Current).171208-0126)</Product>

Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

@v-qiuyu-msft Would really appreciate help with this.

Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

This is still occuring after the March update.

 

@v-qiuyu-msft @mgmeyer @riccardomuti Assistance with this is appreciated.

Regular Visitor
Posts: 22
Registered: ‎05-22-2017

Re: After a scheduled refresh the report has no data

Hi,

I have the same issue.

For me it started today.  Reports, which were working fine on the server with a scheduled refresh, show blank graphs as of today.  If I delete the report on the server and re-publish it, it shows the report correctly, but as soon as I refresh (manually or with an automatic schedule) it goes blank again.  When I refresh the data on the PowerBi Desktop file, it works fine.

Other reports, which are automatically scheduled, work fine on the server.

Is someone investigating this?

Could you please let us know the solution for this?

Thanks.

Kind regards,

Evelien

Frequent Visitor
Posts: 14
Registered: ‎10-03-2017

Re: After a scheduled refresh the report has no data

I havent found a solution unfortunately. I would hope someone from Microsoft would help here.