cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
svishwanathan Helper III
Helper III

Re: After a scheduled refresh the report has no data

Thanks

Highlighted
Administrator
Administrator

Re: After a scheduled refresh the report has no data

Hi All,

 

I am facing the same issue. After going through these comments changed boolen page level filters to text it worked for a day or so then again am facing the same issue. Please let me know if any other way to reslove this issue 

 

Thanks 

Anonymous
Not applicable

Re: After a scheduled refresh the report has no data

Well I'm glad it's not just me. 

I too am experiencing similar issues. I have a number of the same report hosted on the Report Server, each just filtering to a different location (until we can successfully use RLS) for security reasons. Each report is scheduled for a 30 minute refresh of data.

Some of these reports periodically fail to show any of the visualisations, yet everything works fine if I refresh the desktop version.

This results in me having to re-upload to the report server jsut to get everything running again.

 

Very strange indeed. Are there any successful solutions yet?

 

John1
Frequent Visitor

Re: After a scheduled refresh the report has no data

I had a similar boolean issue. I think it is because I used an untyped field as a page filter. Must have been that desktop interpreted it as text or boolean, while service interpreted it as int. When I changed it to the correct type in m query, it worked fine in both desktop and service. I suppose this same issue could arise with data types other than boolean. 

renanc Helper I
Helper I

Re: After a scheduled refresh the report has no data

@Evelien  Dude I've tried to update the gateway, change data format, and a bunch of other things.
Nothing solved my issue, because for the most people this is a gateway issue.

When I first tried to do your method I've failed, but I did it in a similar way, which worked for me:
I have filtered through the "M" MashUp the related values for "True/False" to just show the "True"/Active values, the ones that I needed.

Than it Worked, so thank you very much for exposing how you solved it!

Just wondering, how did you possible know it was a boolean expression issue, like there was some sort of error displaying for you or you searched for it?

alaeddin14 Helper I
Helper I

Re: After a scheduled refresh the report has no data

I've been having this weird issue for a while ! 

The data is SQL Server on premis, the gateway is configured properly, all other reports refresh as expected. 

Only this report, the first screenshot is from Power BI Desktop and the second one is Power BI Online, the data is from SSISDB, when i publish it to power bi online i get empty report (before even refreshing it!) , even when i try to refresh it i remains the same. 

 

Cheers

 

desktop.pngservice.png

thombcook
New Member

Re: After a scheduled refresh the report has no data

Same issue on Power BI Server and changing the data type of the page filter from Boolean to Whole Number fixed the refresh issue. 

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

April 2020 Community Highlights

April 2020 Community Highlights

Info on our Super Users, MBAS content and badges, and updates to our support articles. - Read the full Community Highlights.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

Top Kudoed Authors