cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
markp
Helper I
Helper I

After a scheduled refresh the report has no data

After updating to October release of Power BI Report Server we were very excited to be able to upload reports used with imported data from SQL Server directly.

When we refresh the report with latest data in desktop then upload to the report server it renders fine and all is well.

I then setup the scheduled refresh, after the scheduled refresh happens all the data becomes blank. 

The outline of the report is there but no data is visible.

 

I then use the desktop edit the report and the data shows, I refresh on the desktop and save it to the report server and the data is visible again.

 

In the logs is shows the report is being refreshed successfully.

 

2017-11-28 02:00:01.9115|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Data Refresh.
2017-11-28 02:00:01.9428|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Retrieving PBIX AsDatabaseInfo.
2017-11-28 02:00:01.9740|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Verifying all the data sources are embedded.
2017-11-28 02:00:01.9896|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Verifying connection strings are valid.
2017-11-28 02:00:02.0521|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Streaming model to Analysis Server.
2017-11-28 02:00:05.9583|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Refreshing the model.
2017-11-28 02:00:22.4579|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Removing credentials from the model.
2017-11-28 02:00:22.7704|INFO|222|Processing Data Model Refresh: SessionId: 16766b77-0766-454a-9a77-109fbb2e66c3, Status: Starting Saving model to the catalog.

 

What am I doing wrong? Would appreciate any help.

 

32 REPLIES 32

Hi, Thanks for the reply.

 

My report does not have any Boolean value in the page. And, the issue still persists.

 

 

Same issue. After refreshing, Report becomes blank

I havent found a solution unfortunately. I would hope someone from Microsoft would help here.

Thanks for your reply, @markp

 

@v-qiuyu-msft

@microsoft

Could you please help?  It is a very crucial step to be able to refresh the data on the server, whether manually or automatically.

 

Thanks.

 

Evelien

 

@markp

@v-qiuyu-msft

 

I have found the solution - at least for my reports - and I hope it will also help you.

 

In the page filter of the report I was using a Boolean expression (XXX = TRUE).  By changing the Boolean values in the table (and therefore also in the filter) to a numeric value (XXX = 1), the report after a refresh on the service does no longer return a blank report.

 

So, even though the filter on a Boolean expression works perfectly ok in PowerBI Desktop, it does not on the service after refreshing with a data gateway.

 

Hopefully this will be of any help for your reports as well.

 

Kind regards,

Evelien

Same issue on Power BI Server and changing the data type of the page filter from Boolean to Whole Number fixed the refresh issue. 

v-qiuyu-msft
Community Support
Community Support

Hi @markp,

 

What's your Power BI report server version? Which visual is blank after schedule refresh? 

 

Based on my test in Power BI report server version 14.0.600.437, the report contains a table visual display data fine after schedule refresh completely. In your scenario, please try another browsers to see if the visual still blank. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Version is <Product>Microsoft Power BI Report Server Version 14.0.600.437</Product>

Have tried multiple browsers and doesnt help.

 

@mgmeyer@riccardomuti Do you have any idea about this issue? Thanks. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-qiuyu-msft Any update on this?

This issue is still present even after updating to version:

<Product>Report Server Version 2017.0140.0600.438 ((BI_Server_Current).171208-0126)</Product>

@v-qiuyu-msft Would really appreciate help with this.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!