cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
diogobellucci Frequent Visitor
Frequent Visitor

(500) Internal server error appears after the publishing process

Hi everyone!

 

I tried to publish a report when I was logged with my user and the messsage "(500) Internal server error" appeared. This error does not happen when I try to publish the same .pbix file with other user. Is this problem related with my user account? This error first appered last afternoon (GMT +2).

 

Thank you for your support!

 

Diogo

4 REPLIES 4
v-yulgu-msft Super Contributor
Super Contributor

Re: (500) Internal server error appears after the publishing process

Hi @diogobellucci,

 

Do you publish .pbix file to PBI Report Server or Power BI Service?

 

If it is the former, does your account have a Power BI Pro license?

 

If it is the latter, please log on Power Bi service, upload your pbix files via Get Data -> Files -> Local file to check whether they can be published successfully.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
diogobellucci Frequent Visitor
Frequent Visitor

Re: (500) Internal server error appears after the publishing process

Hi Yuliana!

 

Thanks for your reply!

 

Yes, my account has a Pro Licence (trial).

 

Today the service is working ok... The "solution" I found was delete some datasets from my workspace. But I think memory is not the problem, because I only used 313 MB of 10GB available so far.

 

I have no idea what can be...

 

Diogo

 

 

natrolability Frequent Visitor
Frequent Visitor

Re: (500) Internal server error appears after the publishing process

In my case it was down to some type of file corruption. I managed to fix by exporting it as a PowerBI template (file menu - export) and then reimporting it again which puts it into a blank pbix file. It then was able to re-publish successfully.

Highlighted
milenamocci New Member
New Member

Re: (500) Internal server error appears after the publishing process

Hi, I had the same problem, and we tried to reinstall the program, but it didn't work.

I locked deeply and the file was salved in a dropbox folder, when I salved this file on the desktop I had success and I got to publish it.

 

I hope it can help someone in the future.

 

Helpful resources

Announcements
Ask Amir Anything

Exclusive LIVE Community Event No. 2 – Ask Amir Anything

Next in our Triple A series: Ask Amir Netz questions about the latest updates, features and future.

Ask Amanda Anything Q&A

Ask Amanda Anything Q&A

Learn the answers to some of the questions asked during the Amanda Triple A event.

October 2019 Community Highlights

October 2019 Community Highlights

October was a busy month in the community. Read the recap article to learn about some of the events and content.

New Solution Badges

New Solution Badges

Two waves of brand new solution badges are coming! Read the article for more information on our new community badges.

Users Online
Currently online: 158 members 1,526 guests
Please welcome our newest community members: