cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
diogobellucci Frequent Visitor
Frequent Visitor

(500) Internal server error appears after the publishing process

Hi everyone!

 

I tried to publish a report when I was logged with my user and the messsage "(500) Internal server error" appeared. This error does not happen when I try to publish the same .pbix file with other user. Is this problem related with my user account? This error first appered last afternoon (GMT +2).

 

Thank you for your support!

 

Diogo

3 REPLIES 3
Community Support Team
Community Support Team

Re: (500) Internal server error appears after the publishing process

Hi @diogobellucci,

 

Do you publish .pbix file to PBI Report Server or Power BI Service?

 

If it is the former, does your account have a Power BI Pro license?

 

If it is the latter, please log on Power Bi service, upload your pbix files via Get Data -> Files -> Local file to check whether they can be published successfully.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
diogobellucci Frequent Visitor
Frequent Visitor

Re: (500) Internal server error appears after the publishing process

Hi Yuliana!

 

Thanks for your reply!

 

Yes, my account has a Pro Licence (trial).

 

Today the service is working ok... The "solution" I found was delete some datasets from my workspace. But I think memory is not the problem, because I only used 313 MB of 10GB available so far.

 

I have no idea what can be...

 

Diogo

 

 

Highlighted
natrolability Frequent Visitor
Frequent Visitor

Re: (500) Internal server error appears after the publishing process

In my case it was down to some type of file corruption. I managed to fix by exporting it as a PowerBI template (file menu - export) and then reimporting it again which puts it into a blank pbix file. It then was able to re-publish successfully.