cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
diogobellucci
Regular Visitor

(500) Internal server error appears after the publishing process

Hi everyone!

 

I tried to publish a report when I was logged with my user and the messsage "(500) Internal server error" appeared. This error does not happen when I try to publish the same .pbix file with other user. Is this problem related with my user account? This error first appered last afternoon (GMT +2).

 

Thank you for your support!

 

Diogo

6 REPLIES 6
apods1979
Helper I
Helper I

Hyperchef1969
Resolver I
Resolver I

Hi, we also have an error with updating a specific dataset, after our gateway was updated. 

Failed to load resource: the server responded with a status of 500 ()

 

I already launched a ticket, but does anyone have an idea what the problem is and how to solve?

milenamocci
New Member

Hi, I had the same problem, and we tried to reinstall the program, but it didn't work.

I locked deeply and the file was salved in a dropbox folder, when I salved this file on the desktop I had success and I got to publish it.

 

I hope it can help someone in the future.

 

v-yulgu-msft
Microsoft
Microsoft

Hi @diogobellucci,

 

Do you publish .pbix file to PBI Report Server or Power BI Service?

 

If it is the former, does your account have a Power BI Pro license?

 

If it is the latter, please log on Power Bi service, upload your pbix files via Get Data -> Files -> Local file to check whether they can be published successfully.

 

Regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Yuliana!

 

Thanks for your reply!

 

Yes, my account has a Pro Licence (trial).

 

Today the service is working ok... The "solution" I found was delete some datasets from my workspace. But I think memory is not the problem, because I only used 313 MB of 10GB available so far.

 

I have no idea what can be...

 

Diogo

 

 

In my case it was down to some type of file corruption. I managed to fix by exporting it as a PowerBI template (file menu - export) and then reimporting it again which puts it into a blank pbix file. It then was able to re-publish successfully.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!