Slope Chart by MAQ Software

Frequent Visitor
2309 Views
MAQPowerBI Frequent Visitor
Frequent Visitor

Slope Chart by MAQ Software

Slope Chart allows users to analyze trends in data at a glance. This visual is useful for comparing interactions between two data points based on time or other user-chosen parameters. Slope Chart places primary emphasis on end points by focusing on the difference between the start and end values. Key features include: • The ability to display trends across various indicators. • Quick comparison of indicator growth or loss across categories. • Easy interaction with many data points using the zoom functionality. • Quick downloading of an image of the chart with the capture image widget. R package dependencies (auto installed): plotly and ggplot2

akj2784 Member
Member

Re: Slope Chart by MAQ Software

Is there any configuration required for this. I installed R but it gives error.

 

Feedback Type:
Frown (Error)

Timestamp:
2018-03-20T15:34:01.8087909Z

Local Time:
2018-03-20T11:34:01.8087909-04:00

Session ID:
d7fa6a1d-1dea-4f77-80c3-468e7447324b

Release:
February 2018

Product Version:
2.55.5010.641 (PBIDesktop) (x64)

Error Message:
R script error.
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: ggplot2
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'ggplot2'
2: In libraryRequireInstall("ggplot2") :
*** The package: 'ggplot2' was not installed ***
Loading required package: plotly
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'plotly'
2: In libraryRequireInstall("plotly") :
*** The package: 'plotly' was not installed ***
Loading required package: magrittr
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'magrittr'
2: In libraryRequireInstall("magrittr") :
*** The package: 'magrittr' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Error in plot_ly() %>% layout(title = "", xaxis = xLayout, yaxis = yLayout) :
could not find function "%>%"
Calls: tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
Execution halted


OS Version:
Microsoft Windows NT 6.3.9600.0 (x64 en-US)

CLR Version:
4.7 or later [Release Number = 461310]

Peak Virtual Memory:
34 GB

Private Memory:
307 MB

Peak Working Set:
473 MB

IE Version:
11.0.9600.18953

User ID:
18c4b28a-9bc6-4fc9-97a9-35b75d43d58f

Workbook Package Info:
1* - en-IN, Query Groups: 0, fastCombine: Disabled, runBackgroundAnalysis: True.

Telemetry Enabled:
True

Model Default Mode:
Import

Snapshot Trace Logs:
C:\Users\akjain\AppData\Local\Microsoft\Power BI Desktop\FrownSnapShot536970509.zip

Performance Trace Logs:
C:\Users\akjain\AppData\Local\Microsoft\Power BI Desktop\PerformanceTraces.zip

Enabled Preview Features:
PBI_shapeMapVisualEnabled
PBI_EnableReportTheme
PBI_numericSlicerEnabled
CustomConnectors
PBI_reportBookmarks
PBI_qnaExplore
PBI_variationUIChange

Disabled Preview Features:
PBI_SpanishLinguisticsEnabled
PBI_AdobeAnalytics
PBI_customVisualsGallery
PBI_HanaV2

Disabled DirectQuery Options:
PBI_DirectQuery_Unrestricted

Cloud:
GlobalCloud

Activity ID:
null

Time:
Tue Mar 20 2018 11:33:55 GMT-0400 (Eastern Daylight Time)

Client Error Code:
ServiceErrorToClientError

Error Details:
R script error.
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: ggplot2
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'ggplot2'
2: In libraryRequireInstall("ggplot2") :
*** The package: 'ggplot2' was not installed ***
Loading required package: plotly
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'plotly'
2: In libraryRequireInstall("plotly") :
*** The package: 'plotly' was not installed ***
Loading required package: magrittr
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'magrittr'
2: In libraryRequireInstall("magrittr") :
*** The package: 'magrittr' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Error in plot_ly() %>% layout(title = "", xaxis = xLayout, yaxis = yLayout) :
could not find function "%>%"
Calls: tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
Execution halted


Stack Trace:
Microsoft.PowerBI.ExploreServiceCommon.ScriptHandlerException: R script error.
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: ggplot2
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'ggplot2'
2: In libraryRequireInstall("ggplot2") :
*** The package: 'ggplot2' was not installed ***
Loading required package: plotly
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'plotly'
2: In libraryRequireInstall("plotly") :
*** The package: 'plotly' was not installed ***
Loading required package: magrittr
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'magrittr'
2: In libraryRequireInstall("magrittr") :
*** The package: 'magrittr' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Error in plot_ly() %>% layout(title = "", xaxis = xLayout, yaxis = yLayout) :
could not find function "%>%"
Calls: tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
Execution halted
---> Microsoft.PowerBI.Radio.RScriptRuntimeException: R script error.
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: ggplot2
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'ggplot2'
2: In libraryRequireInstall("ggplot2") :
*** The package: 'ggplot2' was not installed ***
Loading required package: plotly
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'plotly'
2: In libraryRequireInstall("plotly") :
*** The package: 'plotly' was not installed ***
Loading required package: magrittr
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'magrittr'
2: In libraryRequireInstall("magrittr") :
*** The package: 'magrittr' was not installed ***
Loading required package: htmlwidgets
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'htmlwidgets'
2: In libraryRequireInstall("htmlwidgets") :
*** The package: 'htmlwidgets' was not installed ***
Loading required package: XML
Warning messages:
1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
there is no package called 'XML'
2: In libraryRequireInstall("XML") :
*** The package: 'XML' was not installed ***
Error in plot_ly() %>% layout(title = "", xaxis = xLayout, yaxis = yLayout) :
could not find function "%>%"
Calls: tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
Execution halted

at Microsoft.PowerBI.Radio.RScriptWrapper.RunScript(String originalScript, Int32 timeoutMs)
at Microsoft.PowerBI.Client.Windows.R.RScriptHandler.GenerateVisual(ScriptHandlerOptions options)
--- End of inner exception stack trace ---
at Microsoft.PowerBI.Client.Windows.R.RScriptHandler.GenerateVisual(ScriptHandlerOptions options)
at Microsoft.PowerBI.ExploreServiceCommon.ScriptVisualCommandFlow.RunInternal(Stream dataShapeResultStream, QueryBindingDescriptor& bindingDescriptor)
at Microsoft.PowerBI.ExploreServiceCommon.ScriptVisualCommandFlow.Run(Stream dataShapeResultStream, QueryBindingDescriptor& bindingDescriptor)
at Microsoft.PowerBI.ExploreHost.SemanticQuery.ExecuteSemanticQueryFlow.TransformDataShapeResult(QueryCommand transformCommand, SemanticQueryDataShapeCommand command, Stream dataShapeResultStream, QueryBindingDescriptor& bindingDescriptor)
at Microsoft.PowerBI.ExploreHost.SemanticQuery.ExecuteSemanticQueryFlow.ExecuteDataQuery(IQueryResultDataWriter queryResultDataWriter, EntityDataModel model, IConceptualSchema schema, DataQuery query, Int32 queryId, ServiceErrorStatusCode& serviceErrorStatusCode)
at Microsoft.PowerBI.ExploreHost.SemanticQuery.ExecuteSemanticQueryFlow.ProcessAndWriteSemanticQueryCommands(IQueryResultsWriter queryResultsWriter, ExecuteSemanticQueryRequest request, IConceptualSchema conceptualSchema, EntityDataModel model)

DPI Scale:
100%

Supported Services:
Power BI

Formulas:


section Section1;

shared #"CO2 Emissions" = let
Source = Excel.Workbook(File.Contents("C:\Users\gopal\Documents\power bi\proj\data\R visuals data.xlsx"), null, true),
#"CO2 Emissions_Sheet" = Source{[Item="CO2 Emissions",Kind="Sheet"]}[Data],
#"Changed Type" = Table.TransformColumnTypes(#"CO2 Emissions_Sheet",{{"Column1", type text}, {"Column2", type number}, {"Column3", type number}, {"Column4", type number}}),
#"Promoted Headers" = Table.PromoteHeaders(#"Changed Type", [PromoteAllScalars=true]),
#"Changed Type1" = Table.TransformColumnTypes(#"Promoted Headers",{{"Country", type text}, {"2012", type number}, {"2013", type number}, {"2014", type number}}),
#"Rounded Off" = Table.TransformColumns(#"Changed Type1",{{"2012", each Number.Round(_, 2), type number}, {"2013", each Number.Round(_, 2), type number}, {"2014", each Number.Round(_, 2), type number}})
in
#"Rounded Off";

shared #"Department expenditure" = let
Source = Excel.Workbook(File.Contents("C:\Users\gopal\Documents\power bi\proj\data\R visuals data.xlsx"), null, true),
#"Department expenditure_Sheet" = Source{[Item="Department expenditure",Kind="Sheet"]}[Data],
#"Promoted Headers" = Table.PromoteHeaders(#"Department expenditure_Sheet", [PromoteAllScalars=true]),
#"Changed Type" = Table.TransformColumnTypes(#"Promoted Headers",{{"Division", type text}, {"First quart", Int64.Type}, {"Second quart", Int64.Type}, {"Third quart", Int64.Type}, {"Fourth quart", Int64.Type}}),
#"Renamed Columns" = Table.RenameColumns(#"Changed Type",{{"First quart", "Quarter 1"}, {"Fourth quart", "Quarter 2"}, {"Second quart", "Quarter 3"}, {"Third quart", "Quarter 4"}})
in
#"Renamed Columns";

akj2784 Member
Member

Re: Slope Chart by MAQ Software

Could be related to package installation ?

Do we have any documentation for the same ?

akj2784 Member
Member

Re: Slope Chart by MAQ Software

I was able to fix this issue. 

Thanks