cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
y2gabs
Frequent Visitor

scheduled refresh not working for web datasource

Despite there being quite a few posts on here regarding my error, I've struggled to find one that matches so hopefully I'm not duplicating here.  I've created a powerbi report with a web based datasource of a table from yahoo finance.  Everything works fine and I am able to refresh the data no problem in powerBI but if I try to schedule a data refresh in the online app I get the following error about cridentials.. given that my datasource doesn't need cridentials and that this is a pretty standard powerquery setup I'm a little perplexed as to how to solve it.  Any help would be greatly appreciated!  Thanks!

 

"Scheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh."

 

Here is my query:

 

 

 

let
    Source = Web.Page(Web.Contents("https://finance.yahoo.com/quote/AAP/history?period1=1006992000&period2=1608163200&interval=div%7Csplit&filter=div&frequency=1mo&includeAdjustedClose=true")),
    Data2 = Source{2}[Data],
    #"Changed Type" = Table.TransformColumnTypes(Data2,{{"Date", type date}, {"Dividends", type text}, {"Column3", type text}, {"Column4", type text}, {"Column5", type text}, {"Column6", type text}, {"Column7", type text}}),
    #"Extracted Text Before Delimiter" = Table.TransformColumns(#"Changed Type", {{"Dividends", each Text.BeforeDelimiter(_, "Dividend"), type text}}),
    #"Removed Columns" = Table.RemoveColumns(#"Extracted Text Before Delimiter",{"Column3", "Column4", "Column5", "Column6", "Column7"}),
    #"Sorted Rows" = Table.Sort(#"Removed Columns",{{"Date", Order.Descending}}),
    #"Duplicated Column" = Table.DuplicateColumn(#"Sorted Rows", "Date", "Date - Copy"),
    #"Reordered Columns" = Table.ReorderColumns(#"Duplicated Column",{"Date - Copy", "Date", "Dividends"}),
    #"Sorted Rows1" = Table.Sort(#"Reordered Columns",{{"Date", Order.Descending}})
in
    #"Sorted Rows1"

 

 

 

 

1 ACCEPTED SOLUTION
edhans
Super User
Super User

Web pages require a gateway. See this article. This changed in 2018. I suspect MS got some feedback from enterprises that they didn't like users being able to comingle company data with outside web pages without the IT department making sure it was approved and appropriate to do, so they force all web pages to go through gateways now.



Did I answer your question? Mark my post as a solution!
Did my answers help arrive at a solution? Give it a kudos by clicking the Thumbs Up!

DAX is for Analysis. Power Query is for Data Modeling


Proud to be a Super User!

MCSA: BI Reporting

View solution in original post

4 REPLIES 4
Suchitra
Frequent Visitor

I am getting the same error how ever I tried the same  "anonymous" with privacy level as Public but doesn't work for me , is there any other way to solve this....

edhans
Super User
Super User

Yes @y2gabs - once you start mashing up data in the Power Query engine, you must make sure the privacy levels match as well. Glad you got it fixed.



Did I answer your question? Mark my post as a solution!
Did my answers help arrive at a solution? Give it a kudos by clicking the Thumbs Up!

DAX is for Analysis. Power Query is for Data Modeling


Proud to be a Super User!

MCSA: BI Reporting
edhans
Super User
Super User

Web pages require a gateway. See this article. This changed in 2018. I suspect MS got some feedback from enterprises that they didn't like users being able to comingle company data with outside web pages without the IT department making sure it was approved and appropriate to do, so they force all web pages to go through gateways now.



Did I answer your question? Mark my post as a solution!
Did my answers help arrive at a solution? Give it a kudos by clicking the Thumbs Up!

DAX is for Analysis. Power Query is for Data Modeling


Proud to be a Super User!

MCSA: BI Reporting
y2gabs
Frequent Visitor

Thanks!  That seemed to have worked although one addtional step.  It seemed to have been tripping on wanting credentials for a web data source that does not require credentials.  After playing around with it, it looks to not want the actual credentials as much as it wanted to the "Privacy Level" to be consistent between the web service and powerbi desktop settings.  So credentials remains "anonymous" but once I switched privacy level in both to "Public" it seems to have worked.  Very strange but you got me on the right track. Thanks!

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Dev Camp Session 26

Check it Out!

Mark your calendars and join us on Thursday, September 29 at 11a PDT for a great session with Ted Pattison!

Top Kudoed Authors