cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jlacroix Frequent Visitor
Frequent Visitor

on premise gateway data sources dosen't show up under data sets

Hello everybody,

 

I've setup the on-premise gateway and created two ODBC data sources.

Everything seems to work (thats what PowerBI is trying to tell me) but despite the corret users and data sources privacy level settings, the data sources dosent shows up in the Datasets, as you can see on the sreenshots below.

 

Somebody has an Idea what i'am missing here?

Thanks for your support.

Regards

Julien

 

 

 

 

3 REPLIES 3
alanhodgson Established Member
Established Member

Re: on premise gateway data sources dosen't show up under data sets

Hey @jlacroix,

 

In Desktop this is done here: Get Data > ODBC

Capture11.PNG

Check out these articles for more information:

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-data-sources/

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-connect-to-data/

 

Hope this helps,

 

Alan

jlacroix Frequent Visitor
Frequent Visitor

Re: on premise gateway data sources dosen't show up under data sets

Hello Alan,

 

thanks for your support but if I do this, I'll just see the local configured ODBC connections of the workstation from which I'am using Power BI Desktop.

But I wont see the ODBC Data Sources I've configured on the "on premise gateway".

 

yours

Julien

Moderator v-qiuyu-msft
Moderator

Re: on premise gateway data sources dosen't show up under data sets

Hi @jlacroix,

 

After you create a ODBC data source in on-premise data gateway, we need to go to the dataset which connects to this ODBC data source, then set it use the data gateway.

 

From your images, I notice that there is no dataset in your Power BI Service. You need to create a report in Power BI Desktop, which use the same ODBC data source as the one created in data gateway, make sure connection string is the same. Then publish this report to service. Then you can go to the dataset settings, select the data gateway for the dataset like below:

 

q7.PNG

 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Exclusive LIVE Community Event #3 – Ask Arun Anything

Exclusive LIVE Community Event #3 – Ask Arun Anything

Join us in the third Triple A event!

Meet the 2020 Season 1 Power BI Super Users!

Meet the 2020 Season 1 Power BI Super Users!

It’s the start of a new Super User season! Learn all about the new Super Users and brand-new tiered recognition system.

Super User Challenge: Can You Solve These?

Super User Challenge: Can You Solve These?

We're celebrating the start of the New Super User season with our first ever Super User 'Can You Solve These?' challenge.

January 2020 Community Highlights

January 2020 Community Highlights

Make sure you didn't miss any of the things that happened in the community in January!

Top Solution Authors
Top Kudoed Authors