cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

SSAS Tabular Measures working but not showing in excel

Hello,

 

I have a SSAS Tabular model that worked totally fine.

Since a few days, when users connect through in excel and try to add some measures in the values, for some them nothing happens.

 

I checked in the model, I get results for those measures and when I do the analyze in excel it works as well. The only issue is when trying to connect from excel.

 

I have no idea where this issue can come from, so any help is welcome.

 

Raphaël

5 REPLIES 5
Highlighted

Re: SSAS Tabular Measures working but not showing in excel

Do your users actually add the measures to their pivot table, or do they drag and drop the numeric columns these measures are based on?

 

The later will not work in Excel.

Anonymous
Not applicable

Re: SSAS Tabular Measures working but not showing in excel

Add the measures. I tried it myself I have the same issue. Some how the query goes on and then nothing happens (no error message).

Community Support Team
Community Support Team

Re: SSAS Tabular Measures working but not showing in excel

Hi @Anonymous

Which measure do you add, could you show me the formula?

when you add measures, you say nothing happen, what does this mean?

when you add dataset and measures in the table visual,there is no value and the list is blank for the measure, right?

 

Best Regards

Maggie

 

Anonymous
Not applicable

Re: SSAS Tabular Measures working but not showing in excel

Hello Maggie,

 

"When you add dataset and measures in the table visual,there is no value and the list is blank for the measure, right?"

Yes but just for some of them and since only a few days (worked for months without any issues).

Another weird point is that my colleague uses the same measures in another model that is extremely light compared to mine (less than 5 millions rows) and had the same issue all of a sudden as well.

Finally other weird point is that sometimes it starts working again like this morning...

 

Here is an example of one of the measures that brings the issue:

 

Comparable Sales Weekday:=
CALCULATE (
[Total Sales],
'SSS'[Daily Type] IN { "Type 1", "Type 2" },
'SSS'[Aggregated Store Days] >= 23,
'SSS'[Aggregated Store Days Same Date] >= 23,
'SSS'[Opened Month] = "Closed",
'SSS'[Sales Last Year Weekday] > 0
)
+ CALCULATE (
[Total Sales],
'SSS'[Daily Type] IN { "Type 1", "Type 2" },
'SSS'[Opened Month] = "Opened",
'SSS'[Sales Last Year Weekday] > 0
)

 

Thank you for the help,

Best Regards,

 

Raphaël

Community Support Team
Community Support Team

Re: SSAS Tabular Measures working but not showing in excel

Hi @Anonymous

It seems no error in your measure.

Do you connect to a SSAS Tabular model in excel(which connection mode,import or live connection?), then connect to that excel with power bi (power bi desktop? service? import?live connection?)

 

Best Regards

Maggie