cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jnthnshvr Frequent Visitor
Frequent Visitor

SQL Server version required

We have an old SQL 2008 standard server which we have performed some Power BI reports against.  We are upgrading to a SQL Server 2012, and would like to start using row/role-based security with Power BI.  Which version of SQL Server do we need?  Standard, Business Intelligence, or Enterprise?

 

Sincerely,

 

Jon Shaver

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: SQL Server version required

@Jnthnshvr Here is the breakdown in features by edition. You need Business Intelligence or Enterprise to run Tabular, and RLS is included in both editions.

Near SE WI? Join our PUG Milwaukee Brew City PUG
6 REPLIES 6
Super User
Super User

Re: SQL Server version required

Are you using row/role security in SQL or in Power BI?


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


Jnthnshvr Frequent Visitor
Frequent Visitor

Re: SQL Server version required

From our understanding, we would setup the role-based security for the Power BI reports and Dashboards in the tabular database model in SSAS.  So I would say in SQL?

 

Sincerely,

 

Jon Shaver

Super User
Super User

Re: SQL Server version required

@Jnthnshvr Here is the breakdown in features by edition. You need Business Intelligence or Enterprise to run Tabular, and RLS is included in both editions.

Near SE WI? Join our PUG Milwaukee Brew City PUG
Super User
Super User

Re: SQL Server version required

If you really want close integration with Power BI though, I would recommend SQL Server 2016.


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


Highlighted
Super User
Super User

Re: SQL Server version required

I agree with smoupre, if you aren't pressed for time I'd wait for the release of SQL 2016. Or make a place for 2016 to support your BI efforst. It offers so much more in the way of the BI story, capabilities, and performance in tabular models.

Near SE WI? Join our PUG Milwaukee Brew City PUG
Jnthnshvr Frequent Visitor
Frequent Visitor

Re: SQL Server version required

Saw that comparison site, but was not certain if I was reading it right.  Thanks for the assistance!

 

I will pass the info about 2016 along, but I do not know if the people holding the purse strings will wait that long.  Smiley Happy

 

Sincerely,

 

Jon Shaver