cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Prodigy
Post Prodigy

SQL Connection Named Pipes Provider, error:40

Morning,

 

In the past few days I've been having this issue more and more wherein I'm sometimes able to connect to my sql server when I refresh or apply my queries. In the past I was able to work around this by just running the query again; but I'm trying to run some queries over slightly larger datasets (200k rows) and it seems to fail before it completes.

 

I'm not sure how to enable remote connection on my Azure Sql Database in SSMS or through the azure portal so this might be helpful if anyone knows how.

 

I've allowed the port 1433, I've placed an exception for powerbi through Windows firewall. I've tried to run a telnet but my cmd didn't recognise the command.

 

Thoughts?6c981d7259c9003aa9b77fd65bf41436.png

 

 

171d6c00106c7101e03d75cc8a3d6359.png

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Hi @ElliotP,

 

1. Please check if the outbound traffic over port 1433 port is allowed on the machine which has desktop runs.

2. Please add firewall rules to specify which IP address ranges from the Internet are allowed. See: Azure SQL Database server-level and database-level firewall rules.

3. Please enable Telnet Client feature then run telnet command in cmd. See: Windows 7: Enabling Telnet Client.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
Highlighted
Community Support
Community Support

Hi @ElliotP,

 

1. Please check if the outbound traffic over port 1433 port is allowed on the machine which has desktop runs.

2. Please add firewall rules to specify which IP address ranges from the Internet are allowed. See: Azure SQL Database server-level and database-level firewall rules.

3. Please enable Telnet Client feature then run telnet command in cmd. See: Windows 7: Enabling Telnet Client.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

Evening, 

 

Thank you so much for the quick response. I added the port and it seems to be running a lot more comfortably; thank you so much.

Highlighted

So where did you add the ports exactly ? and what ports # ?

Highlighted

Evening,

 

I added the port 1433 to my windows firewall (TCP port).

 

I would reccomend reading the Accepted Solution's linked guide; it's incredibly useful.

 

 

Highlighted

Evening,


The is presenting itself exactly as the same as before. I can confirm I have added port 1433 in my windows firewall as both an outbound and inbound rule.

 

@v-qiuyu-msftI followed your guide and enabled telnet.

 

I follow this guide https://azure.microsoft.com/en-au/blog/sql-azure-connectivity-troubleshooting-guide/ and my telnet what the guide said was successful.

 

I ran a tracert as it suggested and here are the results;

 

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Elliot Parker>tracert 191.239.192.109

Tracing route to 191.239.192.109 over a maximum of 30 hops

  1    <1 ms    <1 ms    <1 ms  NB604N.Home [192.168.1.1]
  2    57 ms    48 ms    47 ms  10.20.23.251
  3    55 ms    57 ms    62 ms  203-213-56-193.tpgi.com.au [203.213.56.193]
  4    56 ms    61 ms    62 ms  cbr-apt-mar-crt2-ge-2-0-0.tpgi.com.au [203.219.1
06.109]
  5    63 ms    61 ms    63 ms  syd-gls-har-crt2-te-0-0-0-3.tpgi.com.au [203.219
.106.117]
  6    48 ms    70 ms    59 ms  syd-sot-ken-crt2-he-0-3-0-0.tpgi.com.au [202.7.1
62.78]
  7    69 ms    73 ms    75 ms  203-219-35-132.static.tpgi.com.au [203.219.35.13
2]
  8    69 ms    65 ms    66 ms  202.7.171.78
  9    76 ms    73 ms    65 ms  ae16-0.mel01-96cbe-1b.ntwk.msn.net [198.206.164.
96]
 10     *        *        *     Request timed out.
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.

Any help would be greatly appreciated. I've been stucking simply trying to apply queries to my data for the past 5 days.

Highlighted

Thanks @ElliotP for your reply. I actually have no control over my windows firewall ports (for technical security reasons). Is there anything that can be done at the Azure side to allow the connection ?!

Highlighted

Morning @aghonaim. My best suggestion is perhaps setup a VM running an operating system that will support powerbi and run it off there; I've considered doing it myself as this is beyond irritating. I've been sitting for days waiting for it to run through (I'm limited by my bandwidth and to a certain degree my computer power).

 

@v-qiuyu-msftPlease save me lols

Highlighted
Regular Visitor

I got this error because I was entering my server name slightly wrong.  So, if you do all of the technical stuff and it isn't working...check the exact server name.  

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors