cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
haric Frequent Visitor
Frequent Visitor

SQL Azure Database with DirectQuery not automatically refreshing the report

I am using a PowerBI desktop to connect to SQL Azure and author my report.

I upload the report to power bi.

But the report refresh doesnt happen automatically. I have to refresh the data set and then the report manually.

 

Is there any work around? 

 

I find that if i login to power bi within a browser and use the Get Data then the SQL Azure connectivity is live.

But i did not want to recreate the whole report within the browser just for this purpose.

Seems a bit weird.

 

Any help appreciated ?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
ankitpatira Super Contributor
Super Contributor

Re: SQL Azure Database with DirectQuery not automatically refreshing the report

@haric it depends on how have you connected to Azure sql db via PBI desktop. Have you used Improt or DirectQuery ? 

View solution in original post

2 REPLIES 2
ankitpatira Super Contributor
Super Contributor

Re: SQL Azure Database with DirectQuery not automatically refreshing the report

@haric it depends on how have you connected to Azure sql db via PBI desktop. Have you used Improt or DirectQuery ? 

View solution in original post

haric Frequent Visitor
Frequent Visitor

Re: SQL Azure Database with DirectQuery not automatically refreshing the report

Thanks i changed the option to DirectQuery and it works.

Helpful resources

Announcements
New Topics Started Badges Coming

New Topics Started Badges Coming

We're releasing new versions of the badge that everyone's talking about. ;) Check your inbox for notifications.

MBAS 2020

Save the new date (and location)!

Our business applications community is growing—so we needed a different venue, resulting in a new date and location. See you there!

Difinity Conference

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)