cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hereri
Frequent Visitor

Problems with security when using Live connection to SSAS Tabular

For one of our customers we have implemented row based security in SSAS Tabular using roles, and then adding members to these roles. When connecting to SSAS Tabular from Power BI the set filters are not having any effect.

 

After doing some digging with SQL Server Profiler (connected to SSAS) I see that<EffectiveUserName> is set to the service account being used to connect to Tabular (same as Logged In User), *NOT* the UPN of the logged in user. This information is returned in the <CustomData> tag. I have a feeling that this might be related. We are using "On-Premise data gateway" for this customer.

 

As as side-note, another customer of ours also have row based security (which works), and here the logged in users UPN is returned in the <EffectiveUserName> tag. The major difference is that this customer is still on "Power BI Gateway - Enterprise".

 

Any clues or hints towards a solution?

1 ACCEPTED SOLUTION
v-qiuyu-msft
Community Support
Community Support

Hi @hereri,

 

In your scenario, did your Power BI service login names match your local directory UPN on SSAS side? If not, please check if you set the Mapping User Roles in on-premise data gateway. For more information, see: Map user names.

 

Also verify the user is not the admin on the server, please refer to AlexeyRusinov's reply in this thread: Enterprise Gateway with Analysis Services not passing logged in users credentials .

 

If issue persists, please share the detail steps about how you set row level security and the on-premise data gateway version for our analysis.

 

Best Regards,
Qiuyun Yu

 

 

 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-qiuyu-msft
Community Support
Community Support

Hi @hereri,

 

In your scenario, did your Power BI service login names match your local directory UPN on SSAS side? If not, please check if you set the Mapping User Roles in on-premise data gateway. For more information, see: Map user names.

 

Also verify the user is not the admin on the server, please refer to AlexeyRusinov's reply in this thread: Enterprise Gateway with Analysis Services not passing logged in users credentials .

 

If issue persists, please share the detail steps about how you set row level security and the on-premise data gateway version for our analysis.

 

Best Regards,
Qiuyun Yu

 

 

 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-qiuyu-msft

 

Thank you for your reply. I did find the answer to my problem. In the map user functionality you can decide if you want to use EffectiveUserName or CustomData. Since my browser was in Norwegian the translated text completely threw me off and I did not see the relevance between that option, and how Power BI pushed UPN to SSAS. 

 

Thanks alot for your help 🙂

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Show Episode 10 Recap

The Power BI Community Show

Watch the playback when Amit Chandak, a Power BI Super User, demos how to use Field Parameters to make reports more dynamic.

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Health and Life Sciences Power BI User Group

Health and Life Sciences Power BI User Group

Power BI specialists at Microsoft have created a community user group where customers in the provider, payor, pharma, health solutions, and life science industries can collaborate.

Top Kudoed Authors