cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ANCHOVIEPIZZA Frequent Visitor
Frequent Visitor

Problems with custom visual and R

Hey all,

 

I'm trying to do some forcasting and downloaded the custom visual 'Time Series Forecasting Chart'. I subsequently had to download R 3.4.3.

However, when i come to populate the chart i receive the following error. Does anyone have any clues as to why this has gone wrong?

Thank you!

-----------------------------------------------------

Feedback Type:

Frown (Error)

 

Timestamp:

2018-03-22T17:09:36.4916522Z

 

Local Time:

2018-03-22T17:09:36.4916522+00:00

 

Session ID:

b37894b6-dbcd-4dd5-acd2-a45c3344368d

 

Release:

March, 2018

 

Product Version:

2.56.5023.1021 (PBIDesktop) (x64)

 

Error Message:

R script error.

Loading required package: XML

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'XML'

2: In libraryRequireInstall("XML") :

*** The package: 'XML' was not installed ***

Loading required package: htmlwidgets

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'htmlwidgets'

2: In libraryRequireInstall("htmlwidgets") :

*** The package: 'htmlwidgets' was not installed ***

Loading required package: ggplot2

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'ggplot2'

2: In libraryRequireInstall("ggplot2") :

*** The package: 'ggplot2' was not installed ***

Loading required package: plotly

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'plotly'

2: In libraryRequireInstall("plotly") :

*** The package: 'plotly' was not installed ***

Loading required package: scales

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'scales'

2: In libraryRequireInstall("scales") :

*** The package: 'scales' was not installed ***

Loading required package: forecast

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'forecast'

2: In libraryRequireInstall("forecast") :

*** The package: 'forecast' was not installed ***

Loading required package: zoo

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'zoo'

2: In libraryRequireInstall("zoo") :

*** The package: 'zoo' was not installed ***

Loading required package: ggplot2

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'ggplot2'

2: In libraryRequireInstall("ggplot2") :

*** The package: 'ggplot2' was not installed ***

Error in ggplot() : could not find function "ggplot"

Execution halted

2 REPLIES 2
ANCHOVIEPIZZA Frequent Visitor
Frequent Visitor

R script visuals not working, here's the error - can anyone help?

Hey all,

 

I need to do some forecasting so downloaded the 'Time series forecasting chart' from the store. I then downloaded R version 3.4.3.0.

 

However, when i go to use the visual i receive the error below. Does anyone have any idea why?

 

Feedback Type:

Frown (Error)

 

Timestamp:

2018-03-22T17:09:36.4916522Z

 

Local Time:

2018-03-22T17:09:36.4916522+00:00

 

Session ID:

b37894b6-dbcd-4dd5-acd2-a45c3344368d

 

Release:

March, 2018

 

Product Version:

2.56.5023.1021 (PBIDesktop) (x64)

 

Error Message:

R script error.

Loading required package: XML

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'XML'

2: In libraryRequireInstall("XML") :

*** The package: 'XML' was not installed ***

Loading required package: htmlwidgets

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'htmlwidgets'

2: In libraryRequireInstall("htmlwidgets") :

*** The package: 'htmlwidgets' was not installed ***

Loading required package: ggplot2

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'ggplot2'

2: In libraryRequireInstall("ggplot2") :

*** The package: 'ggplot2' was not installed ***

Loading required package: plotly

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'plotly'

2: In libraryRequireInstall("plotly") :

*** The package: 'plotly' was not installed ***

Loading required package: scales

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'scales'

2: In libraryRequireInstall("scales") :

*** The package: 'scales' was not installed ***

Loading required package: forecast

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'forecast'

2: In libraryRequireInstall("forecast") :

*** The package: 'forecast' was not installed ***

Loading required package: zoo

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'zoo'

2: In libraryRequireInstall("zoo") :

*** The package: 'zoo' was not installed ***

Loading required package: ggplot2

Warning messages:

1: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :

there is no package called 'ggplot2'

2: In libraryRequireInstall("ggplot2") :

*** The package: 'ggplot2' was not installed ***

Error in ggplot() : could not find function "ggplot"

Execution halted

deldersveld
Advisor

Re: Problems with custom visual and R

Custom visuals should attempt to install dependencies if they're not available. Not sure why that's not happening for you, but you can manually install the packages it requires by opening R and running the following "install.packages()" command to get all the packages the error message mentions.

 

install.packages("XML", "htmlwidgets", "ggplot2", "plotly", "scales", "forecast", "zoo")

 

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 53 members 1,171 guests
Please welcome our newest community members: