cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MelissaSnell
Helper I
Helper I

PowerBI desktop - PostgrSQL data seems to load in Query Build but fails to load in Report Builder

This is a bit of a weird one.

I am trying to use PowerBI desktop to generate reports based on a PostgreSQL database.

I am on a Windows 8.1 Professional laptop and I followed the instructions to make sure that the various DLLs.

Both Npgsql.dll v2.2 and Mono.Security.dll are installed and in the GAC.

 

I can create a datasource and build a query based upon it without any issues. The problem comes when I try to load the query in order to base a report on it. When I have a single query, I found that if - after the first error - I clicked "load" 4 times, then suddenly it would work for no apparent reason. The error messages are telling me that there is a connection problem to the data source.

If I look at the postgreSQL logs it might be indicating that it is refusing the connection based on SSL negotiation.

 

Are there any known issues that could explain this behaviour? I can't understand why the data loads perfectly in the Query Build but then refuses to load in the main report builder.

 

Any help would be greatly appreciated.

1 ACCEPTED SOLUTION
MelissaSnell
Helper I
Helper I

UPDATE: Upgrading the npgsql DLL to the latest release 3.0.1 seems to have resolved the issue.

https://github.com/npgsql/npgsql/releases/tag/v3.0.1

 

In case it helps anyone I created a dummy project in Visual Studio 2012 and installed the package using nuget.

 

I then copied the DLL out to a different location and used the Visual Studio Developer command prompt to uninstall the existing DLL from the GAC and then install the new one.

View solution in original post

3 REPLIES 3
MelissaSnell
Helper I
Helper I

UPDATE: Upgrading the npgsql DLL to the latest release 3.0.1 seems to have resolved the issue.

https://github.com/npgsql/npgsql/releases/tag/v3.0.1

 

In case it helps anyone I created a dummy project in Visual Studio 2012 and installed the package using nuget.

 

I then copied the DLL out to a different location and used the Visual Studio Developer command prompt to uninstall the existing DLL from the GAC and then install the new one.

View solution in original post

hi,

 

Can someone please tell the steps that needs to be done to connect postgresql.

 

I am geeting the error the download npgsql, which I did but I dont know the further steps

See if this helps:

http://www.postgresql.org/message-id/438d02260901061216ndfce75bx42824b0e83fd21a@mail.gmail.com

 

I found I needed to look on this site for how to use .NET to access PostGreSql.

 

You need the right versions of mono.security and npgsql. Make sure you use the latest DLLs recommended because that solves a bunch of connection issues.

 

Let me know if you are still stuck and will try and give you more details if I get an email notification that you have replied

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Top Solution Authors
Top Kudoed Authors