cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Power BI desktop gives error (415) Unsupported Media Type with only certain OData feeds from NAV

Trying to connect Power BI Desktop to Microsoft Dynamics NAV 2016 via OData, both on premises.

 

Set up some OData feeds a few days ago, and those are still working. However, any new ones give the error "OData: Request failed: The remote server returned an error: (415) Unsupported Media Type. (Unsupported media type requested.)"

 

On one client, this can be fixed by replacing servername.domain.local with just servername in the Odata path, but on another it fails both ways.

 

You'd think it was a name resolution issue, but the exisiting Odata feeds to the same server address still work!

 

And ALL the Odata feeds work perfectly in Excel.  So why should only new ones be failing, and only failing in Power BI ?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Power BI desktop gives error (415) Unsupported Media Type with only certain OData feeds from NAV

I've been struggling with this same issue for a few hours, and I think i've found the solution. Power BI caches data from OData feeds, meaning it will hold the data from the first time you consumed the OData feed. When you want to add data from a new NAV object and enter the URL using "Get Data" Power BI will return a error, because according to the cached data the newly added object doesn't exist. I've found 2 ways to solve this:

 

1. Lets say NAV gives you the following OData URL: http://localhost:7048/DynamicsNAV90/OData/Company(CRONUS)/Query. In Power BI Desktop: when pasting this link in the OData-feed using "Get Data" remove the last part of the URL (http://localhost:7048/DynamicsNAV90/OData/Company(CRONUS)/). This will open the query editor and shows you all the available objects in NAV(according to the currently cached data). Now go to "Start" in the ribbon and click "refresh preview". The OData feed should now be updated and the correct objects should be shown. From here you can select the object you want to use and load it in.

 

2. In Power BI Desktop: Go to "File"  and select "Options". Under "Data Load" you have the option to clear the cache. After doing this you can use "Get Data" and "OData-feed" as normal and the URL won't return the 415 error. 

 

Quite simple but it worked for me!

View solution in original post

3 REPLIES 3
Highlighted
New Member

Re: Power BI desktop gives error (415) Unsupported Media Type with only certain OData feeds from NAV

I have exctly the same issue  (not working in powerBI - working fine in excel) - did you found a solution ?

 

Highlighted
New Member

Re: Power BI desktop gives error (415) Unsupported Media Type with only certain OData feeds from NAV

Same problem here. Someone have a solution. Some Odata works fine other no why?

Trying to understand the reason could help the solution

 

Highlighted
Advocate I
Advocate I

Re: Power BI desktop gives error (415) Unsupported Media Type with only certain OData feeds from NAV

I've been struggling with this same issue for a few hours, and I think i've found the solution. Power BI caches data from OData feeds, meaning it will hold the data from the first time you consumed the OData feed. When you want to add data from a new NAV object and enter the URL using "Get Data" Power BI will return a error, because according to the cached data the newly added object doesn't exist. I've found 2 ways to solve this:

 

1. Lets say NAV gives you the following OData URL: http://localhost:7048/DynamicsNAV90/OData/Company(CRONUS)/Query. In Power BI Desktop: when pasting this link in the OData-feed using "Get Data" remove the last part of the URL (http://localhost:7048/DynamicsNAV90/OData/Company(CRONUS)/). This will open the query editor and shows you all the available objects in NAV(according to the currently cached data). Now go to "Start" in the ribbon and click "refresh preview". The OData feed should now be updated and the correct objects should be shown. From here you can select the object you want to use and load it in.

 

2. In Power BI Desktop: Go to "File"  and select "Options". Under "Data Load" you have the option to clear the cache. After doing this you can use "Get Data" and "OData-feed" as normal and the URL won't return the 415 error. 

 

Quite simple but it worked for me!

View solution in original post

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Community Summit Australia – Join Online!

Community Summit Australia – Join Online!

Be a part of the leading Microsoft Business Applications digital event, curated for the APAC community.

Top Solution Authors