cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
prnair Frequent Visitor
Frequent Visitor

Power BI & SharePoint SSO issue

  • I have a customer using O365 SharePoint Online site and also have the Power BI Dashboard create for their Enterprise users. They have ADFS configured for user authentication.

    Now the issue is SSO (Single Sign On) is not working when they move from SharePoint Online site to PowerBI Dashboard - they are getting logon prompt everytime they open the PowerBI dashboard. But they are able to open other SharePoint site without been prompted for userid and password.

    Is there any configuration need to be done at PowerBI site (or even at SharePoint/O365) to have this SSO to work even for PowerBI.

    Any help or direction will really help.

    Thanks in advance.
     
    Regards,
    Pradeep Nair
2 REPLIES 2
Super User
Super User

Re: Power BI & SharePoint SSO issue

Hmm, you do not seem to be the only one having this issue, unless of course, catclaw63 is you.

https://social.msdn.microsoft.com/Forums/en-US/465fd150-2fc6-4209-af4d-c305d467541f/adfs30-single-si...

 

There is also a thread on it here:

http://community.powerbi.com/t5/Service/ADFS-Deep-Link-to-Dashboard/td-p/19140

 

There seemed to be the start of a resolution if you read down near the bottom of the thread. But not sure it was ever resolved.


Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!


prnair Frequent Visitor
Frequent Visitor

Re: Power BI & SharePoint SSO issue

Thanks smoupre for the response. I have already seen those thread, I will be trying those deep link url query string and enable Windows Auth on the ADFS server.

 

Regards