cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Power BI Gateway connect to Azure via Proxy

[edited to correct Subject - not sure where that came from.]

Hi,

 

I installed Power BI Gateway, way-back when there were two separate installers for Personal vs Enterprise and managed to get it working through our proxy, by setting the <defaultProxy> etc in the appropriate config files.

 

So now I'm installing the current (non-personal) version, freshly downloaded (3000.2.47).

I've updated the .config files for the Configurator and the Service itself, switched to using HTTPS only for the Azure Service Bus.

 

But I can't for the life of me get it to connect to the Azure Service Bus during the Diagnostics | Network ports test.

 

I've run NetMon and can see that the connections from the Configurator are using the proxy.

And I can see some of the connection from the Service itself are also using the proxy (connections to dc.services.visualstudio.com).

But all the connections to *.servicebus.windows.net insist on trying to connect direct, which just won't work on our network.

 

I've used:

<system.net>
<defaultProxy useDefaultCredentials="true">
<proxy
autoDetect="false"
proxyaddress="http://[OURPROXY]:[OURPORT]"
bypassonlocal="false"
usesystemdefault="false"
/>
</defaultProxy>
</system.net>

 

for both the Configurator and the Service. The proxy is currently set to no authentication, to keep things simpler.

 

Any ideas?  This used to work in the (way) old version...

 

Thanks
Craig

2 REPLIES 2
Highlighted
Moderator v-yuezhe-msft
Moderator

Re: PBI Desktop connect to Azure via Proxy

@Anonymous ,

Are the proxy settings same in old version of gateway and new version of gateway? If so, please open a support ticket in Power BI support site.

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: PBI Desktop connect to Azure via Proxy

Pretty sure it's the same.  I've posted to the Issues forum and will update this post if/when there's an outcome.