cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Personal gateway can't identified

I need a gateway to publish a Power BI file which linked to local SQL server. So I installed On-Premises(Personal Mode). 

But when I accessed Power BI website and tried configure "Gateway", there showed nothing.

It looks like I don't have any gateway.

How can I configure personal gateway?

1.png2.png3.png

1 ACCEPTED SOLUTION
New Member

Finally, I found the route cause!!

 

It was because "DirectQuery"!!

 

Personal gateway doesn't support "DirectQuery" mode. So I can't find gateway in datasets. 

 

I created a brand new PBIX file using "import data" instead of "DirectQuery". Now I can use personal gateway.

 

Anyway, thanks a lot for all your help.

View solution in original post

5 REPLIES 5
New Member

Finally, I found the route cause!!

 

It was because "DirectQuery"!!

 

Personal gateway doesn't support "DirectQuery" mode. So I can't find gateway in datasets. 

 

I created a brand new PBIX file using "import data" instead of "DirectQuery". Now I can use personal gateway.

 

Anyway, thanks a lot for all your help.

View solution in original post

Super User III
Super User III

Next step is to make sure the gateway service is actually running on your PC, and then to add the connection to the gateway (in the Manage gateways section for enterprise gateways, not sure how that works for personal gateways)

 

Make sure to use EXACTLY the same connection details on the gateway and in your PBIX file.

 

If the gateway is still not visible you may have other on-prem datasources in your PBIX file that you need to declare in the gateway.

Thanks for your reply. But I still can't see any gateway in "Manage Gateways".

 

I didn't add any on-prem datasources in my PBIX file. I just inptut the sever name and datasource name in PBIX.

 

Also I really don't understand how to check if the personal gateway actully running on my laptop, cause I can't find its icon in the taskbar. 

 

 

 

Look in Services. It should be listed there as running.

OK, here's my situation.

I downloaded two on-pre gateways both, enterprise and personal.

I installed personal version, login my organization account, I didn't find on-pre gateway in windows servise even the software shows it's running online.

Then I installed enterprise version, but I can't login my organization account, but I found "On-presmies gateway" in servise, showed it's running.

However, either way I tried didn't workout. I still see nothing in "Manage gateways" of Power BI website.

Helpful resources

Announcements
secondImage

Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors